Khitan Bow - Infinite Repair Cycle

Game mode: [Singleplayer]
Problem: [Bug]
Region: [Character Taskbar]

Khitan Bow. Used it and worked fine. Its durability was dropping, so with materials in my inventory, I selected it and chose “Repair”. The gear icon started up, but its not repairing. I tried to remove it from task bar, but it says it cannot be removed while it is repairing. Its been in the repair cycle, gear still going, and not getting any better, for nearly two hours now. Its “stuck” in repair mode and cannot be moved, removed, equipped, or stopped.

EDIT: Also, same problem when trying to get it repaired in the Carpenter’s bench – infinite cycling to repair without it actually repairing.

2nd EDIT: Upon death, the repair cycle stopped and the bow could be removed from the task bar.

Steps on how to reproduce issue:

  1. Put a Khitan bow in your character task bar.
  2. Use it until it needs repair (mine was about half damaged when I tried repairing it)
  3. See if it will let you repair it.
  4. Repeat.

Yep, confirmed. You can remove it from task bar, drop it onto bag on floor - where it remains in gear mode for repair, pick it up, drop into carpenter bench, still with gear on it, remove all materials for repair and it still is stuck. Until it gets fixed, use it until it’s totally broken, maybe that will fix the thing.