[Known Issue] Gamepass PC version Freezes while traveling across the map or while admin teleporting

Game mode: Single-player
Type of issue: Crash
Server type: PvE
Region: USA/Gamepass PC
Mods?: No

Bug Description:

Gamepass PC - Windows 10. RTX 3080, 64 gig ram, Intel Core i7 10700K.

Game will periodically freeze when travelling around the world. The current frame is frozen on screen, and background ambient sounds continue. The game must be force quit via the task manager. Once this happens it is very easy to reproduce by simply walking in the same direction again once you load up the save file again.

This typically happens while walking for a long distance on the world. Resuming the game and attempting to travel in the same direction will continue to freeze the game. Using admin teleport will also freeze the game, but this time it will freeze on the loading screen with the progress at a very low percent. It feels very much like trying to load certain region of the map cause the freeze. If I do this many times, eventually i can journey into the problem area.

Expected Behavior:

Game does not freeze while walking around on the map.

Steps to Reproduce:

All I can say is play the Gamepass PC version with my specs and try to admin teleport around a bit and or walk long distances. I have tried several solutions suggested in these forums including: full reinstall, reducing graphics settings, turning off g-sync, and also some ini file modifications about garbage collecting. No luck.

Same thing happens to me

Same thing happens to all members on my server can’t even use map room and freezes going through different biomes

All on gamepass

Same here! It happens on Xbox Game Pass every time I play with my friends, long trip, teleporting, admin teleporting.

Hello everyone and thank you for providing us with all this information.

We’ve passed this over to the rest of the team for further investigation.

Thank you for your patience while we investigate.

Thank you.

Currently the only work around I’ve found to this problem is to either stay within the same area, or if freezing starts while travelling a long distance, restart the client over and over and continue walking in the direction that is freezing. Eventually you will progress to the new area. The only downside to this solution other than taking lots of time, is that when you inevitably return home you will begin freezing again going in the other direction.

If anyone has a better solution let me know!

Hello, since Conan Exiles came out for the microsoft store I went to download it immediately, but I have realized that it has many errors, mainly I thought that they only happened to me but no, I have two friends from different areas of Spain who have just the same problems as me and my boyfriend has the steam version and has no problem about it.

  1. My first problem is when the server disconnects or I have to quit the game, the screen freezes and forces me to open the task manager to force close it, it may even make me have to log out of my windows user.
  2. My second problem is when I pass certain areas of the map, when I go for example from the desert to the Nordheimer area nothing happens, but when I go down to the desert in the area of ​​the albino bat for example from that line of the map I stop the game and crashes, this also happens in jungle areas.
  3. These are no longer big problems, they are just doubts, for example the microsoft store nudity dlc allows partial nudity, but not complete nudity. And also that it does not allow me to enter servers with steam mods, I do not know if there will be any way to do it.

Thanks for your attention, also say that my English is bad so sorry if everything is not understood perfectly.

You should be able to connect to modded servers by following this guide:

For the rest of the issues, you are not alone. Here is the latest by Funcom:

Btw, are you using Razer Mouse and/or Keyboard? If so, this may help:

Same here, xbox gamepass is terrible

My friends and I installed Conan Exiles on gamepass, the game is awesome but there are so many bugs and I have to restart the game EVERYTIME.
I walk on desert the game just STOP and I have to log into it again. The worst experience ever.

i’m dropping the game, that’s so sad and frustraiting because i was loving it so much.

Game mode: Co-op
Type of issue: Crash
Server type:*PvE

Mods?: *[ Are mods installed: No
Edition: *Microsoft Store with gamepass

Bug Description: Crashing near ruins north of original spawn point consistently. If i walk towards it the game hard locks. I’m unable to control panel close it. I’m forced to restart my PC to close the game. It happens every time we open the game and attempt to walk in any way towards it or around these ruins. We’re basically stuck and can’t get back to our base. I think the ruins are “The Summoning Place”

Now Today i’m not having the issue of being unable to connect to servers. After opening the game it just sits at “connecting to servers”.

I’m running conan exiles on pc through the game pass app.

Same here, but im on a player hosted server. Fast travelling, dieing or sometimes on certain spots of the map. The game just freezes. Ya lose all control. Like you said the only way of closeing the app is signing out or restarting the pc. Im also on the xbox pass version. Pleaseee fix. Its super inconvenient.

1 Like

Same here. Just started happening today. Worked fine yesterday. We ran up to the ruins… getting ready to sneak on in… and my screen freezes and kicks all my friends off line (I’m the one hosting). :frowning: Tried it with just me and it’s still an issue.

Just a question, do you by any chance use Razer Mouse and/or Keyboard? Furthermore, Funcom are investigating and hopefully, have a patch/fix soon:

I am using a razer keyboard but my friend who it was locking up for too was not.

1 Like

Game mode: Solo official
Type of issue: Freeze
Mods? : No

Bug Description:

Random, by foot, on horse or admin teleport, game freezes, cannot close by task manager, sometimes Ctrl+Esc an launch game again wont force a session close or hard reset.

Expected Behavior:

I should move freely

Steps to Reproduce:

  1. Load your save
  2. Try to travel
  3. freeze
  4. Restart, start game again
  5. Not your last position, 5 min ago aprox
  6. Lose your thrall, horse and progression

Merging some duplicate reports into this thread. We highly recommend using the Search :mag: tool to see if your question or report has already been brought up.

We’re working to have a patch out for the GamePass PC version as quickly as possible. This should alleviate the issue.


I’m also on the game pass. The razer app thing didn’t work for me, but using a controller did. Now I’m freezing and crashing when walking into random areas of the map, so I’m giving up. I’ll have to play later when it is playable.

all my friends are with the same issue using gamepass. only one friend of mine is using steam and 0 issue