"Lost connection server" Get kick out to main menu, please HELP

Hello, I just can’t connect to the game. I can only play in solo or coop when my friend join me.

When i try to join a server, it kick me out to the main menu and says “lost connection server”

I tried to restart steam, i just download conan for the 3th time and it is still kicking me out !

I really need help i tried everything and i always can’t join a server.

If someone can help me please!


I have also had this issue. I also use steam to run it. I would say the problem is steamside but my buddy can connect to online servers and I cant? not sure what the problem is or who I need to contact to solve it. Whether it is funcom, steam, or my internet service provider. So although I dont have an issue. At east you know someone else is suffering with you. lol

*dont have and answer is what I meant. I DEFINATELY have an issue. lol

I am also having the same issue. I have tried numerous online fixes. So far, no luck.

this is becoming a serious issue for me as well, and no response from the devs… faith in funcom further dropping… this is a beta game now. there’s no excuse for game breaking bugs to not be addressed.

1 Like

Agreed. Been having this issue as well.

Same here. Everything looks good, good server ping etc. but ~5 minute loading screen and “Server timeout” dialogue. Seems intermittent like this morning there was no problem but tonight it’s been two hours now.

Also having similar issue. Playing on xbox kicked me out last night and wouldn’t let me log back on says connection to server lost. Tried again today getting same thing. My daughter using her account but the same internet connection logged on to the server just fine in the other room. So I logged in to her xbox on my account and it still would not let me log on to offical server pve 2501. She was able to log back on just fine. It’s happened before but not anywhere close to this long. Seems to be an issue with my account? Seeing as how she can log in on the same internet connection.

“Connection to host server lost”

anyone find a fix for this?

Anyone fixed this issue?

This is still an issue, can rarely connect and if I do connect usually get kicked in about 10 mins. On one server I built a house and then couldn’t log back into the server, by the time I got back in my house had decayed :frowning: