Master Mason Journey Will Not Update

Hello! I am stuck on the “build or upgrade a building piece” part of this quest. I have upgraded like 4 different pieces at various tiers and it won’t work. I have gone from T1 to T2 and taken T2 to T3… nothing. I even just built a standalone T2 piece. What am I doing wrong? :frowning:

Hello, and welcome to the forums.

Since you’re on PC, the first and obvious question it: are you using any mods? Some mods change item IDs in the game, so the Journey system no longer recognizes those building pieces properly.

But even without mods, some journey steps sometimes get a little stuck. I remember having to try the Master Mason one several times with different flavors of building pieces. I think it completed when upgrading a sandstone wall to a stonebrick one, but it has been some time so can’t be sure.

Thank you. I did actually get it to update but it was after I had given up. I had tried everything then I went back to building my house and I used one of the DLC building pieces and then it magically worked… :smiley:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.