Missing save data, missing buildings, armour, followers ion

Basic Info:

Platform: Xbox Series X
Issue Type: Other
Game Mode: Co-op
Server Type: PvE
Server Name: Don’t know

Bug Description:

My wife and I play Conan together with separate accounts. We both purchased a copy back in Feb. When we logged in today we could ony find save data for one account. All the buildings, armour, followers were gone for the other. Please help.

—Update: Siptah loads fine with all save data present. Tried reinstall but exiled lands still not showing any previous work. It’s like when she signs in to the exiled lands on her account it puts her in my world. There is a lot of work/time in her save and we just want to get it back.
– Update: tried erasing local data and restart with cloud save data. No change.

Bug Reproduction:

Signed in

1 Like

Same here, but Siptah has missing elements as well for me. I play singleplayer/co-op play.

Thanks for the reply, is your stuff just missing? Her’s is actually loading in my dave data. Have you had anything like that happen?

Still no change after the update. Any further advice would be great.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.