Mods not updating correctly?

Ever since mid July I have been struggling to get my mods to update. I get a bunch of Assertion Failed: !m_bISFinalized errors for all the mods. I did a bit of searching and someone suggested deleting the appmanifest file. I tried that and it worked, but today even deleting the appmanifest file is having no effect. Just spammed with errors on all the mods.

Mod List
Age of Calamitous - 1113901982
Level 60 Legendary Chest Req. - 1369100856
Level 140 - Unlock Everything - 1368506289
Drag Thralls in water - 1384471264
75% More women - 1273074761
Single Player boss HP II - 1378725683
Increased Breast Physics - 1368720532
Female Wheel of Pain - 1366532201
Bark ByProduct - 862116109

Again, everything was working fine just a few weeks ago, and I even got all these mods working just a couple days ago. Now nothing will update and server keeps saying order is wrong though I’ve verified multiple times.

Edit - the full errors is:
\src\common\contentmanifest.cpp (650) : Assertion Failed: !m_bIsFinzalized

There are also assert_steamcmd.exe.dmp files being generated though I don’t have a program to open them.

So far I’ve looked through steams list of conflicting programs. Disabled all firewalls and closed all other programs. Still receiving this error, has anyone else seen this?

I started to see this on my server shortly after first setting the mods up to update together using steam cmd last month. I had a few good runs before that error message started spamming. The mods appear to still update just fine, I just have no idea what the error is or how to fix it.