Mounts wont follow through gates

Game mode: Online private
Type of issue: Bug
Server type: PvE-Conflict
Region: EU

Mounts are unable to follow through gates, also criters wont follow through gates. They stop as if it was closed, or as if there was a wall. Criters seem to have no issues with regular small doors.

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. Ask horse to follow
  2. Cross a gate
  3. Horse stays on the other side and will eventually teleport closer to you instead of just walking.
1 Like

All I can say is that it the same for me. I have never seen my horse crossing a gate if I am not riding it. I make turns outside waiting for him to teleport behind me.

I think the best will be to be able to open gates while on the horse (but maybe it is an issue in pvp then). Because bringing back a knocked out thrall is painful since you also loose the link when going up/down from the horse.

1 Like

I though that was one of the standard “bugs” (I could make a list of all the gameplay habits I have taken to walk around issues like this). But our base is on standard square foundations, gate on the edge and stairs going down. Nothing fancy. If you tell me that horses can go by themselves through gates, I will try to extend foundations outside through the gates before starting with the stairs. I can post a screenshot of the current situation later if needed.

1 Like

Everyone knows that mounts have FTL technology and would rather warp through the gate at the speed of light and meet you on the other side. It just takes a while for them to load their FTL engines. :joy:

1 Like

I understand now! This is why when I go through a river by swimming, they have time to load the FTL engine and instantly TP next to me when I arrive on the shore. Make sense :upside_down_face:

True, very true!

Even if you take the Gates away they still stand there. What i have also noticed is that if you close the gate before the mount teleports on the other side, it will stick its head inside it and you wont be able to interact with the gate anymore, trapping you inside your own base( i have an emergency exit when this happends).

1 Like

To come back on the subject, hereunder are inside/outside screens of a gate impossible to pass by themselves for our horses (at least to go out, I did not pay attention going in since I am not trying to re-use the horse). I can live with it though, there are more important points to fix but if there is an easy build fix I am open for suggestions.

Correct. We own no mods/DLC so its all vanilla. I will post later screens from the inside if you’re interested.

This is like 99% likely to be an issue with the gate’s foundation stones. There’s probably like a 1 inch rise from the ground to the foundation, not enough to interfere with the character in any way, but it absolutely screws with AI pathing. I had this at an oasis base one time, and I noticed the purge appearing in my base all the time, even when the gates were open during purge. They couldn’t path in, so they teleported.

I later noticed horse stopping at the gate and teleporting to me on my way in or out, and it occurred to me there might be a small rise. I put stairs on both sides of the foundations - almost a complete waste, but it fixed the issue. Both horses and the purge could now properly path into the base, so the teleporting stopped.

No, my gates don’t have a step, they are built with foundations on one side and foundations on the other side, continuous. Also on other gates they have foundations on one side and ceiling tiles on the other.

Note that I have a drawbridge on this one, the horse will get on the drawbridge (when entering), but once I finish crossing the gate where the bridge is placed it will teleport somewhere… on the way out he just teleports:

I notice the common building pattern on all those is gates on the edge of square foundations, then rows of triangles after. Wonder if that has anything to do with it.

No, in the begining I had it ontop of square foundations both before and after, and the results wre the same.

I have not tried it with the gate being in the center of the foundations, might try to see if it works, but the issue is that it looks awfull to my building style…

I tried it with only square foundations, and the gate in the center of the foundation insted of on the edge, the result is the same.

I have tried without foundations on the sides, with gate not completely on the edge… the horse acts like if there was an invisible wall. Thralls are going through without issue though…

Here is the inside pic for the fun of it

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.