No option to pick new server

There is no dropdown box to pick the new server, just settings and play buttons. I’ve clicked every inch of the launcher and can’t find the option anywhere.

Only paid can go there. If you’re subbed then sounds like a job for support.

Yeah, wish me luck.

Try an install of the other client?

You mean the old client instead of the new one?
Ok, Installed the old client but I can’t even login to that one. No chars are showing after clicking login button. But the new client works fine except for no server option.

While I unfurtunately have no idea on why it wouldn’t be showing, you could try this:

  • Open the launcher
  • Press shift-tab once
  • Press arrow down to select the Rubi-Ka 2019 server and hit play
  • Press arrow up to select the original server and hit play

Thanks a lot. I got the box up and used the arrow keys to change the selection and was able to log in. I think the problem is I play on a 4k monitor and the launcher is tiny.

you prolly have the desktop zoom to more than 150%.
I have 4k too and am using 150% zoom.
The Selection Box is barely usable for me.
I guess with higher desktop scaling its not visible at all.

Yeah, mine is at 175%.

Try this