PC - Age of Sorcery Performance Patch - Discussion Megathread

Please use this thread to discuss PC Age of Sorcery Performance patch. Discussions of other patches and platforms should not be held here but in their respective forum sections instead.

3 Likes

The mirror issues are still there.
i made a short clip to show you. Its like visual glitches to the character.
Mirrow Visual Glitch - Youtube

I can’t progress in any challenge after the lastest patch. I complete the asked task and it won’t pass 1/X no matter how many times I complete the tasks.

It’s a bit weird, but since this patch my fps generally seems to be a tiny bit better when I am in base although only if I look in a direction away from the main part(production) of it, but if I look towards the most busy area of the base my fps now seems to be slightly worse than before the patch… Can’t really explain it better :slight_smile:
My base is a bit big with a decent amount of placeables, but still I was able to have an average of 70-80 fps no matter where I was, now I see huge spikes ranging from 50 fps and to my max setting 120 fps, mostly though around 60-70 fps now, not a big deal but the spikes seems to cause more jitter when looking around or moving fast.
Also my character seems to slide quite a lot after stopping movement, might have to try and lower the max fps to 60, this seemed to work in the past when I experienced this sliding effect as if I am standing on slippery ice :slight_smile:

1 Like

Hi zebode,

Thank you for bringing this to our attention. We are currently looking into this further to determine the cause of these issue.

Thank you for your patience and understanding while we investigate.

1 Like

Still no change for Midnight Alchemist on Siptah.

It is way, way, way too difficult to get this recipe on Siptah and it’s simply a QoL recipe. A very simple fix is to just add it to the drop pool for the central surge. Midnight Alchemist (more specifically the Potion of Bestial Memory) should be no more difficult to get than cooking recipes or learning a new religion. Right now it is a low probability RNG gamble to either get the potion drop from a world boss (expires in 2 minutes), or get the recipe from schematic fragments (1/200) at the pools.

3 Likes

I don’t know if this is patch related but something in the Bazaar seems off…

when I logged in before work today about 2pm Est to check the new Bazaar items coming in today, I saw that the Crystal Ball was there for like around 200 CC, I think.
(Not sure about the price, but I am sure it was there though, because I was looking forward to buying it after work)

Now I logged on after the patch and the Crystal Ball is gone, even though it should have been there for 2+ days.
In it’s place is the Viking Horn emote now.

Was the Crystal Ball there as a mistake or is the horn a mistake?

Since chapter 2 the oficial server i play 1977 the unique latam pve-c every day by evening becomes unresponsieve and any one who tries to join freezes in the loading screen. We come back from work and cant play. I spent my time reporting in forum and zendesk to end up with tickets being closed without solution, the todays patch didint solve the problem. This is the first game that we had to beg for play. The game is amazing and i love and support it but the FC disdain with LATAM pve-c players is makigin the indignation greater than the apreciation.

  • Addressed several exploits in regards to bypassing physical walls.

What’s this all ABOUT? I can still poke trough walls, i can still loot bags through walls etc so what this fix actually fixes?

  • Grey Foxes can now be damaged. But at what cost.

Grey fox FINALLY fixed? Bravo, didn’t took so long or DID it?

  • Fixed an issue that caused failure to reequip weapons after exiting climbing mode.

Sounds awesome - wonder if that actually WORKS this time.

That long time between patches and so barely any fixes / content? Seriously that was what new predatory monetization was for? Most of patch notes consist of performance patches that are actually impossible to prove if they are not just small hotfixes yet STILL there’s bugs that need attention for yesterday. Im done supporting this game in any form.

Challenges should be working as intended again. Please let us know if you find any other issues.

We appreciate your patience and support on this matter.

2 Likes

could someone show me a picture of the new items to come in the shop? (Leak)

Hit and Hold E on a placed element, a foundation for example, or a thrall, makes the game crash.
Hit Esc for Menu, then Settings and keys binding, the game crashes too.

have you also discovered any bugs that would be useful for the players?.

do you understand what i’m talking about? :stuck_out_tongue:

Myself and others are now being plagued by the bug that does not allow you to use healing items. The only fix we found was to log off and back on to the server. But that fix only lasts 5-10 minutes. We are all playing on official sponsored Funcom servers for isle of Siptah. We rarely ran into this issue before the update and now it’s a constant issue.

Português BR

@Funcom_Community O servidor oficial 1977 PVEC não funciona já faz 3 dias e até agora não tem como fazer LOGIN todos estamos sem entrar mas não é a nona vez que falo isso aqui pois esse servidor não funciona bem com o conan após 3.0 sorcery

1 Like

dumb question… have you tried mounting a horse and then dismounting it? Thats the old work around for the healing potion bug…

1 Like

Since the latest patch I can no longer make rose bushes in the artisan’s table. Official Server (1042).

1 Like

Followers do a lot less following since this patch. I constantly find myself alone with my thrall nowhere in sight for extended periods of time. Commands to move, attack, and return are ignored.

As of the latest patch my rented server isnt working and the tech support said its because Microsoft hasnt updated their version of Conan and the server wont work until they do. I play on pc and purchased through xbox app not steam.

coryc Customer Support 09.02.2023 - 00:41

The windows version is one update behind the Steam version the serevr uses. Untikl Windows updated their version of Conan, You will not be able to connect.

Kind regards,
coryc


GPORTAL, Inc
3416 Hillcrest Dr
Waco, TX 76708


CEO: Sascha Wintz

We did not, we did not have mounts with us. And after dying and running back for our bodies we called it a night. I will try and see if that trick still works.

1 Like