PC Patch (03.09.2019) - Battle Standards, New Weapon types, further balancing and more!

After this update if i play more than 30min i got FPS drops and freez. I had fix 60fps but now 2-45fps …after this.

My advice is after every update or patch, run a verify files on steam. Sometimes wierd issues happen, and that makes sure you get all the right files. Even without updates, I’ve done it on ocassion when I have problems connecting to servers. Hope it helps.

2 Likes

Verify files after every patch, it’s mandatory because the game is pretty much guaranteed to give a corrupted/missing pak error if you don’t.

eu server 1043. after update. verified cache x 2. keeps fatal error and crashing. then unable to load ping too high. :anguished::anguished:

Hey @martycus

We tested on server 1043 and we could log in normally and with no crashes (there seems to be a sizeable amount of players in it as well). Could you let us know your system specs and graphic card driver version?

Am experiencing a bug where my bows go to 0 condition after applying the new Master weapon fitting. Has happened on a Hollowbone, a Huntress, and a Eye of Khan so far.

Might be a good idea to alert people to this issue before thousands of bows are destroyed…

is it me? or there is no more finishers with 2 handed swords? the skeletons in hte unanmed attack faster meaning they will interrupt your attacks, and almost stun lock you,

i dont really like what you have done with the 2 handed swords.

2 Likes

Strange, because i was in game right now and tried the stuff from the new dlc, this also with LBPR like mostly, and i didn’t see any crash. To mention, this was a singleplayer trial, so may be server related (wouldn’t be first time).

Right, still a precious advice when you run into any issues, especially after an update or patch.

It definetly is strange, but you know how this game goes, sometimes a problem for one is a non-issue for others. I myself haven’t had a single issue so far in modded private server, so it is hard to identify why all problems come up…

New dlc : foundations

Tried the dlc stuff, and looked at the foundations. With this dlc we have 2 different square foundations, and 2 different wedge foudations. They are similar but coming with different textures, sandy and not. Would be nice having them shown as foundation 1 and 2, or else, hard to figure out what is what in a chest, or in inventory.

But love the new elements, great done !

Also the new armour-sets are awesome. The swords looks great, and work nicely. :wink:

4 Likes

awesome - for those having issues…

… first thing I did was went to steam and verified integrity of game files.
(Not that you should do this - but I delete everything but the game file and let it repair)
Ive had issues with patches/DLCs in the past without doing this, and repair always had me up and running.

So far - pretty solid, haven’t tried any of the goodies out yet though… :slight_smile:
Hoping I can make banners even though Im single-player to put in my house, etc.

1 Like

Totally hoping - wishing that all new building materials in here, magically make their way in the other DLCs. (Dont think they can do it now - for marketing reasons)… but hey, would be sweet to have Khitan versions of the steps, etc. :slight_smile:

2 Likes

Groper and Cooked Groper were renamed to Grouper, but Groper Trophy was not renamed.

#spellchekkerfail :fish:

The Over head chop finisher is a single standalone button now. The kick was removed and replaced with it for 2H. Whatever PC button that is. It is L2 on PS4 controller.

So what part of stream new stuff supposed be FREE!. were is it when you said free.

Same. It seems i can’t land a full heavy combo on a skele or even any mob that has somewhat fast attacks or just attacks between two swings. (Wasn’t the full heavy combos on any weapon uninterruptable before?, i’m not sure so correct me if I’m wrong.) But I like the new two handed sword animations and the patch overall. Great work!

I’m having an issue with applying the new weapon fittings from the Blood and Sand DLC to certain weapons. When I try to modify the weapon it says “cannot modify this item with this modification”. I’ve tried it on the Destroyer, which drops from the warmakers dungeon and it worked fine, but when I try to apply it to Yog’s Touch, World Breaker, or Axe of the Gate Guardian it doesn’t seem to work at all. I don’t know if this was intended or is a bug. Please let me know because this is frustrating to say the least. Thank you.

PS. The weapons have not been damaged in any way nor have they been fitted with any other modifications.

@Holland_Hammer If you are referring to the master weapon fittings, they need the weapon to be with base durability value above 1500. When applying the fitting, the durability will be reduced by 1500. All the weapons you mentioned except for the Destroyer are below the min. base durability required.

Furthermore, there are no new weapon fittings in the DLC. Please let us know which fitting you are trying to apply to which weapon so that we can test.

Certain weapons cant be modified at all which is intended e.g the claws.

Hey @Bone, welcome to our community.
We’re aware of that issue and it’s been fixed internally already. Should come out in the next hotfix.

Ordering a new round of whipping for our #spellchekker team. Thanks for the heads-up.

Everything in the patch except for the DLC. You can peruse the contents of such DLC in this announcement.

1 Like