PC Patch 3.0.2 - Discussion Megathread

The only mod on my server was “faster pet levleing” which doesnt change the hp of the pets just the xp needed. I have the follower perk that adds 20 to all attributes which is not as bad. Sadly though my server uses the Better Thralls mod which allows us to have more then 1 follower (mine is 2 max, 3 with the ingame perk) but after the update the undead id has been changed making them marks as undead not warriors so now you can only ever have 1 undead with you not 2 or 1 undead+ any other follower
So with 1 update I cant play as a necromancer with undead body guards. All they are good for is guarding the base :confused: and my greater shalebacks do that better anyway

Feedback is that you guys clearly need to use testlive for even small patches. I can’t start my server after this hot fix. I had enough trouble 12 days ago with the major update and trying to mod by mod test a mod order that would work. I expected plenty of updates from issues with the 9/1 update. It took you 12 days to just fix the lack of an item granted with store purchases. I don’t see any notices about the pc mod mismatch issues we keep seeing here. It’s pretty major when the list says okay, but it really isn’t.

Yes, I use mods. Before someone says well you have no right to complain because you use them; that is simply not true if a game supports modding. Therefore, if the issue is on Funcom and not the moders side, then it is a Funcom issue and needs to be addressed.

You were great showing all the new things coming with 3.0, plenty of communication. Where is that now with planned fixes? People are generally more patient and less frustrated when they have an idea what is going on.


you can just check your server log for the list of problematic mods, or simply attempt to start your game with all your mods loaded and it won’t load and tell you which one is the problematic in an error message.

That is how they are designed. They last for around 24hrs, slowly losing max HP until they’re no more.

hey how can i tell what mod is causing the crash? its a all a bunch of gibberish to me sadly :upside_down_face:

Well my game told me as I was loading up conan that a file was corrupted & it told me where on my PC I could locate the file I just took that mod off my mods list & it worked fine

my server won’t even turn on for me to do that …

The ironic thing is that I tried to log into an EU Test-Live Server yesterday and the game crashed during the character creation process.

Has the disappearing (Unable to Pickup) mysterious figurine bug for Siptah been fixed yet with the new hotfix ?

Others have reported it has been fixed. Not tested it myself yet.

That’s good to hear, there may be a hope that I can play again and build my offline base when the mods work again.

Sooo we still can’t climb…?

So I’m running Game pass on PC…

I can finally see the official servers… after 4 reinstalls. Just not mine, which is not optimal.

1 Like

Any news Funcom ??? Its not normal that my server doesnt work, I dont even have any mods… Like woke up funcom …What are you guys doing… its been more then 24 hours for a patch that was less then 1 gb … like how can you screw up an entire game with a patch less then 1gb. And now that you know you screw up why dont you put the game like it was before the patch and fix your patch before putting it back … How hard is that???


Care to elaborate what is wrong with your server?

I was getting the message that my game wasnt at the same version of the server since the patch they did yesterday, but it seem fixed now. I was able to logged on 2 min ago.


Can anyone summarize whats the status after 3.0.2?

I am running a dedicated server with several (few) mods. No total conversions, mainly quality of life (see: [EU] New casual player oriented server - PVE-C Siptah)

Since 3.0.2 I can’t connect anymore; my client will state that a PAK file is corrupted and refuse to start the game after connecting to the server.

Do we need mods to be updated? How can I find out which mod it is? All my mods have now been updated so they use the 3.0 devkit (I use G-Portal and none of the mods are shown as outdated / all newer than sept 1st).

Whats wrong? How can I fix it?!

Okay, here’s a brief and blunt summary then.
They plugged a security hole that allowed mods to load assets from outside their intended libraries.
As such every mod that didn’t follow programming “best practices” is now marked as corrupted and will not load.
There have been rumors that mod authors merely need to sit back and wait for Funcom to revert the change - not going to happen, they simply need to update their mods and move all the assets their mod loads to their respective folder.

When you try to start the game with a mod that fits said criteria, there will be an error message telling you exactly which mod is the culprit as well as the filepath to it. It’s also written into the log on the server as well when you attempt to start the server with one such mod.

So to summarize, this change has nothing to do with how long ago a mod was updated or what devkit it used, it simply has to do with how the mod functions and where is it trying to load assets from.

Thanks for your reply!

So when the mods are enabled, and the server starts, and I am able to connect to it using the game client, this would mean that I don’t have any of those mods on my server, since otherwise the server would not even start?
Or is it hidden somewhere in the tons of warnings and stuff you see in the server log, but the server will still start? Which log message am I searching for exactly?

This is the error I got:


And it turned out, that actually my game installation was broken. Indeed verifying files showed 4 bad files, which then downloaded again. I can now play again, also with the mods I had.

So I was actually confusing a corrupt game installation with the mod issues which came with 3.0.2.

Logged in this morning and had/have the following issues:

In the Bazaar:

Crom Coins not displaying correct amount - restart computer and restart game

Crom Coins appear but purchase of Illusion Khitan Captain armor fails - restart game

Challenges/Battle Pass/Bazaar - All display Exclamation point as each of the tabs fails to load - restart computer and restart game

EDIT: I just saw the Funcom post on Twitter about this issue.