[PC-PVE] [NA] LOST EMPIRE recruiting builders and explorers


#22

Edited for event promotion and fresh discord


#23

Here is funny 36 dad player i have kids and wife so i need to escape in Conan exiles haha… im from Finland so timezone might be issue maybe? If u want good player nd temworker add me on Steam colt24fin… i have played this game solo to lvl40 and even killed 2 bosses on my own but now id love to play with friends


#24

Hi Slick! You’re welcome to join us! Hopefully the ping and timezones won’t be a barrier! Come on over!


#25

discord link is old cant use it… Ping is not gonna be an issue 1000mb inet :slight_smile:


#26

A fresh invite! https://discord.gg/kx3XY6


#27

Seems like a nice group so far hope you still have space, is the purge enabled?


#28

Hi Spazmatic. We still have space. :slight_smile: We have purge enabled and at a tougher difficulty. Its not a perfect experience as there are still a number of oddities with the system. That said, if you call out in Global, a number of us will rally to help out. It’s sort of like a block party. :slight_smile:

Discord Invite: https://discord.gg/GqRkhD


#29

Hello thanks for the response! sadly it seems the invite Expired.


#30

Updated post with fresh Discord and benefits

Discord Invite: https://discord.gg/HUbzfs


#31

Bump Bump, Still looking for people to join. We have added the Pippi Mod to the server to add more content.
Check it out and see if it will be a server for you to grow with the community.
We have a great core group, Admin is always available to help if needed. Low build space, you can literally build next to each other. Have a small community inside the game.
Come have fun with Quests and added battle arenas.
Again this server has the Pippi Mod installed. We have a discord as well.
Fresh Discord Link Below


#32

Hello, would like to try this server as it seems to match for what I am looking for. I tried joining and said my authentication was invalid so am assuming I require a pw or something. Thanks!


#33

negative, there is no pw for the server. Make sure you install the Pippi Mod first maybe?


#34

I had the mod but didn’t have enabled >.< All working now. Thanks for the quick reply.


#35

Bump Bump Bump Bump