PC Update 2.4 Official Discussion Megathread

do we at least have an ETA for the fix ? yesterday ppl already tried to raid my base, we were lucky one of us was able to log in and defend, but i doubt today will be as simple and my internet is not so good so downloading again will take at least a whole day

Greetings,

We are working closely with Microsoft to solve this issue, unfortunately with no ETA so far. Once we have further news we will update this thread.

Thank you for your patience and apologies for the inconvenience.

6 Likes

Yeah sorry, this is a measure to prevent automated spam. I’ve bumped your level up a little so you should be able to post images now.

Hi Andy. Made a Funcom account just for this issue. I’m also getting error code 0xd05e0108. I’m using the Xbox app on Windows, Game Pass for PC. I only have one drive (C:), and I’ve been using a few mods. The only thing different that I know I’ve done that I haven’t seen talked about in this thread yet is:

I’m in the US, but changed my region in Windows to the UK in order to download the “regional specific DLC” and access the full, uncensored version of the game (Google it; it’s a common workaround for Xbox users). I haven’t gotten this to work for me yet, but that may just be because I’m on PC; still troubleshooting it. Note that the game played just fine the past couple of days, even after changing regions and back, etc.

I’m not sure if the others changed regions as well and that’s what’s causing this issue, or if it has nothing to do with the error. Also note that I couldn’t seem to find this particular error code anywhere on Microsoft’s official lists of error codes, though I haven’t done an in-depth search (however there is history of other people posting about it for ARK, etc. as you shared).

1 Like

Thanks for the update and info. Yeah, the vexing part is the error has no official public-facing definition anywhere that I can find. We’re looking into it!

1 Like

Some further information for you:

Since my last message, I’ve actually gotten the game to work… sort of. When my region is set to the UK, there are 2 “versions” of the game that show up in the Xbox app for me to launch: one that is just the game, & one that is apparently a “bundle” of the game + regional specific DLC. This was the case a couple days ago as well. I am able to launch and play the game via playing the “bundled” version, and both servers and singleplayer works.

Only problem I’ve run into with it: my mod folder has disappeared. Not sure what happened, but somehow this update/error has resulted in my mod folder being deleted from my (C:) drive entirely (both the bundled and non-bundled versions of the game) and mods having to be re-enabled via Xbox app.

Totally unrelated, but: when, if ever, do you think the PC Game Pass version of the game will be uncensored, as it is on Steam? I understand the decision likely lies with Microsoft, but perhaps you could shed some light on the situation.

1 Like

Hey, I’m new to pc gaming and a d drive isn’t showing, am I doing something wrong?

In a nutshell, the computer’s main hard drive is always labelled “C:” and additional drives go up alphabetically from there (D:, E:, F:, etc.). If you only have a C: drive showing up when you check on Windows, then that’s all you have and you shouldn’t worry. In the example shown, the person has an additional hard drive.

3 Likes

ah okay, so how should I go around the d drive issue?

If you only have a C:\ drive then there is nothing more to do (and nothing wrong on your end as the user).

If I’m not making sense please let me know and please describe exactly what the issue you’re experiencing is.

3 Likes

people are saying you can only update if you have d drive, and I have the error that says 0xd05e0108

Gotcha. If you don’t have a D: drive then don’t worry about it - not much you can do there. We’re still investigating the matter; more news as soon as we’re able to share.

2 Likes

Update from Scott J about what’s been going on:


Hey Exiles,

I wanted to update everyone on a few of the urgent issues we are working on with the Microsoft Store/Xbox App version of the game.

Yesterday we released version 2.4.5 which addressed some certification issues and fixed a client freeze that could happen when teleporting (admin teleport, dying, entering a dungeon, etc). Unfortunately we discovered that the Microsoft Store / Xbox App was giving an error code 0xD05E0108 to anyone that tried to update from 2.4.4 to 2.4.5.

We have been in communication with Microsoft about this issue and we just discovered that it is due to an error in the patching system. This is not something we control and Microsoft has told us they will try to fix it as soon as possible. Until the patching issue is fixed the only way to update to the new version is to uninstall the old version and download the game again.

For our next update (2.4.6) we will need to modify several files to work around the bug with the patching system. Unfortunately this will result in a large patch (estimated to be ~70-80GB).

I apologize for the inconvenience and want to let you know we are doing everything we can to work around these hurdles. I’ll update as soon as we know more from Microsoft.

Thanks,
Scott

7 Likes

That’s a shame that we will need to download another 70-80 GB update in the future but I understand the issue wasn’t on your end. I apologize for being rude earlier as I was frustrated with the freezing issue having cost me my items multiple times, to then having the game not update and when i decided to reinstall I was dead and lost all my items again.

I understand this particular issue wasn’t your fault and I’m sorry.

4 Likes

We appreciate your understanding and believe us, we totally get how frustrating freezing up and losing progress must be on top of getting an unknown error to boot. This is hardly an ideal situation but we’re doing what we can to work around the issue in the meantime.

Edit: And I certainly apologize if I seemed short or flustered; I was caught off guard by the issue and since it was emergent, I didn’t have a ton to go off of yesterday until we were able to investigate further. Thanks again for your patience and understanding. :smiley:

8 Likes

I made an account, specifically to post this.
I don’t usually say stuff like I’m about to. I am always the first to criticize or bash dumb s*** online and s*** on CMs.
(apparently I cant use S*** on this board? )

I am reading everything here because I am pissed I can’t play right now. But honestly, AndyB is on it. I feel they have gone above and beyond the role they have, and negativity directly towards them is undue. Honestly, this forum is blessed to have them.

Having said that, AndyB I know you are reading this. Where are our dongs on xboxgamepass? AndyB. The Dongs. Where are they? Where has Funcom hidden them? I need answers. I sent you my dong question. Please respond. No joke. More than I want the game to work for me right now, I want to know why I can hang out with my hang down. Steam can do it. I know it can. How to enable manhood pls.

1 Like

Olá e boa noite a todos, eu obtive o mesmo problema que muitos aqui presentes eu tentei resolver o problema que veio com a atualização desinstalando o meu jogo, porém eu consegui obter outro tipo de erro para instalar o jogo novamente. Os erros são, (0x803fb107) (0x80073d02), digitados pois por eu ser novo não posso adicionar imagens ou prints.

This is so painful… Well, maybe I’ll reinstall the game in a few months and see if it works at a later date. I think two weeks of a broken game sitting on my PC is long enough.

Okay, here is a question. Is there a place to get an older revision for dedicated servers? I cant update my client yet because gamepass, but my dedicated server on my steam machine is the current version. I cant join that server with the old revision on game pass, but I can launch the older version from the start menu.
The server revision is 299146/29534
The Gamepass revision is 296540/29534
I realize it’s a bit of a longshot, but wanted to know. Thanks.

Not possible, no.

If you need to play right away, a reinstall (per the above information) will let you get in now.

1 Like