PC Update 2.4 Official Discussion Megathread

In a nutshell, the computer’s main hard drive is always labelled “C:” and additional drives go up alphabetically from there (D:, E:, F:, etc.). If you only have a C: drive showing up when you check on Windows, then that’s all you have and you shouldn’t worry. In the example shown, the person has an additional hard drive.


ah okay, so how should I go around the d drive issue?

If you only have a C:\ drive then there is nothing more to do (and nothing wrong on your end as the user).

If I’m not making sense please let me know and please describe exactly what the issue you’re experiencing is.


people are saying you can only update if you have d drive, and I have the error that says 0xd05e0108

Gotcha. If you don’t have a D: drive then don’t worry about it - not much you can do there. We’re still investigating the matter; more news as soon as we’re able to share.


Update from Scott J about what’s been going on:

Hey Exiles,

I wanted to update everyone on a few of the urgent issues we are working on with the Microsoft Store/Xbox App version of the game.

Yesterday we released version 2.4.5 which addressed some certification issues and fixed a client freeze that could happen when teleporting (admin teleport, dying, entering a dungeon, etc). Unfortunately we discovered that the Microsoft Store / Xbox App was giving an error code 0xD05E0108 to anyone that tried to update from 2.4.4 to 2.4.5.

We have been in communication with Microsoft about this issue and we just discovered that it is due to an error in the patching system. This is not something we control and Microsoft has told us they will try to fix it as soon as possible. Until the patching issue is fixed the only way to update to the new version is to uninstall the old version and download the game again.

For our next update (2.4.6) we will need to modify several files to work around the bug with the patching system. Unfortunately this will result in a large patch (estimated to be ~70-80GB).

I apologize for the inconvenience and want to let you know we are doing everything we can to work around these hurdles. I’ll update as soon as we know more from Microsoft.



That’s a shame that we will need to download another 70-80 GB update in the future but I understand the issue wasn’t on your end. I apologize for being rude earlier as I was frustrated with the freezing issue having cost me my items multiple times, to then having the game not update and when i decided to reinstall I was dead and lost all my items again.

I understand this particular issue wasn’t your fault and I’m sorry.


We appreciate your understanding and believe us, we totally get how frustrating freezing up and losing progress must be on top of getting an unknown error to boot. This is hardly an ideal situation but we’re doing what we can to work around the issue in the meantime.

Edit: And I certainly apologize if I seemed short or flustered; I was caught off guard by the issue and since it was emergent, I didn’t have a ton to go off of yesterday until we were able to investigate further. Thanks again for your patience and understanding. :smiley:


I made an account, specifically to post this.
I don’t usually say stuff like I’m about to. I am always the first to criticize or bash dumb s*** online and s*** on CMs.
(apparently I cant use S*** on this board? )

I am reading everything here because I am pissed I can’t play right now. But honestly, AndyB is on it. I feel they have gone above and beyond the role they have, and negativity directly towards them is undue. Honestly, this forum is blessed to have them.

Having said that, AndyB I know you are reading this. Where are our dongs on xboxgamepass? AndyB. The Dongs. Where are they? Where has Funcom hidden them? I need answers. I sent you my dong question. Please respond. No joke. More than I want the game to work for me right now, I want to know why I can hang out with my hang down. Steam can do it. I know it can. How to enable manhood pls.


Olá e boa noite a todos, eu obtive o mesmo problema que muitos aqui presentes eu tentei resolver o problema que veio com a atualização desinstalando o meu jogo, porém eu consegui obter outro tipo de erro para instalar o jogo novamente. Os erros são, (0x803fb107) (0x80073d02), digitados pois por eu ser novo não posso adicionar imagens ou prints.

This is so painful… Well, maybe I’ll reinstall the game in a few months and see if it works at a later date. I think two weeks of a broken game sitting on my PC is long enough.

Okay, here is a question. Is there a place to get an older revision for dedicated servers? I cant update my client yet because gamepass, but my dedicated server on my steam machine is the current version. I cant join that server with the old revision on game pass, but I can launch the older version from the start menu.
The server revision is 299146/29534
The Gamepass revision is 296540/29534
I realize it’s a bit of a longshot, but wanted to know. Thanks.

Not possible, no.

If you need to play right away, a reinstall (per the above information) will let you get in now.

1 Like

PC Gamepass…
I uninstalled the game and downloaded/installed again. Now I can again access the Official servers. I just hope today’s maintenance won’t mess it up again.
Have a great day out there

1 Like

Still nice to see such answers, tks.

I can understand very well the frustration to have to download an other 70-80 GB patch. I know, depending connection, some need longer than others to download game-patches, or simply run out of space.

I’m playing the game on PC, trough Steam install since very EA. Can you imagine all patches i saw since, not to speak the patches i had to download since the game was also pushed to consoles, and now MS gamestore ? What should i say ? :crazy_face:

1 Like

Any eta on this one?


Not at this moment, no. We have assurance it’ll be fixed as quickly as possible, but beyond that we do not have an estimate.

I tried uninstalling so i could then reinstall for the update, but now it wont let me redownload it. The icon stays there with an error, i cancel the update, it disappears, then i go to download the game again and before i click anything the icon comes back saying there’s an error. Anyone have a way around that?

Edit: Had to Restart my PC. Seems like the xbox app is just dropping the ball all over the place.

1 Like

Estou com o mesmo problema, já tentei resolver de todas as maneiras possíveis, e não tem o que fazer na realidade, tem que esperar a consideração e a agilidade de serviço da plataforma.

I uninstalled the game but xbox game pass won’t let me download again, I tried restarting my pc and fully turning off and on but the same error code comes up. also there are two versions showing up in the store and neither work

1 Like