People are unable to sign up for the game, and going to "Account" Link does not work!

Woot! I was able to go in last night and do the purchase, also change passwords thank you so much for having this fixed!


It looks like this problem has returned, can someone please look into this for us all again? :sleepy: I assume the same server that does authentication is also taking crash reports, fills up, and then locks up once the reports queue is full. Any change you could set it to flush to a second archive if that is the case? so it does not keep getting packed?

Any, its happening again can you please help us all with this issue? we cant login to the account server. Cant make new characters etc. Cant reset passwords.

Hi there @alonadel ,

The site itself does not appear to be down, so this appears to be a different issue. Could you please message me directly? I may have to ask for account details and I can’t do that in a public forum.


How do i message you directly? sorry never tried that in the forums before.

No worries. You can click on my avatar in a post and then click the “Message” button that pops up in the little window. I’ll message you.

Im having this issue on my accounts. like all 3 of them… I jsut bought the colonist bundle and went to activate it and now im locked out of everything and the pre generated password funcom sent me doersnt work on either site OR the game login. I jsut paid funcom 45 bucks and im kinda pissed.

Cannot log in to any of my accounts. I can log in to the game, but not into any accounts.

I cant find the message button? Please help!

Well its working now dont know why

Cant log in to account page.

Still Down

can also use assistance on this issue

I am having the same issue, I just want to update the subscription, what is going on with this ?

did you ever get help with this? I was able to login 2 days ago but now I can’t…

Hi There

My toon Karahitooo crashed when entering in Clan agency today . And since this time , i can’t come back in game with this toon. Its seems that only this toon is concerned by this bug
Could you solve this plis ty

Best regards

June 11, 2022 i am unable to create a new account on the account signup page, ive tried multiple times to create and account and it gives the success message when im finished so i try to login and says my pw or username is incorrect, so i tried a little test and tried making an account with same username i have on another one of my accounts and it tells me username is in use. So i try to remake the “new” account again and it gives me success message and not the “username already in use message” safe to say that the new account just isnt being created even tho no errors are coming up in fact it tells me the creation is a success each time, proving that the account doesnt already exist.
Please help with this i would like to make a new account…

Hi, did you get this fixed? I’m having the same problem except I get an error message saying an error occurred while trying to create your account

1 Like

Trying to make a new account to start playing today, same issue.

" A Error occured while attempting to create your account"