Perhaps a snap error


#1

Hi,

I’m trying to place the last piece in the floor, but it won’t snap, i got foundation down in the buttom.

i’m playing on official server #100 PvE Normal

I would love to attach a printscreen but i can’t upload picture or write links in the text.


#2

http://s000.tinyupload.com/?file_id=12230635263678935121


#3

Hi, if you’re certain it’s not overlapping landclaim, please proceed as normal. This happened to me recently on official, with the last. block. :frowning:

Anyway, you’ll run into this conditionally from time to time. What I like to do is have a spare sandstone ceiling in my hotbar. If you can place a ceiling, then there’s no reason why you can’t put a foundation there.

If you can place a ceiling but when you toggle to a foundation and still cannot place it:

  1. Go to First Person. Place the ceiling there.
  2. Delete the ceiling. Don’t move.
  3. Place the foundation.

#4

i found a work around, placed a pillar, but i had to remove the ceiling above it and place it again before i could place the last ceiling on the picture.

But now i got another issue with the roof, i have tried in many different ways and i can’t get the inverted thatch wedge sloped roof to snap to the outside on the picture, and it the same issue all the way around on the roof.
I have tried to build over and under, nothing works, it just won’t snap.

I was trying to place 2 Thatch Wedge Sloped Roof with the inverted in the middle.

Edit: still have issue with image and links

http:/ /s000.tinyupload.com/?file_id=40674474168828989923


#5

You can use a Repair Hammer to check the Stability of the building pieces you are placing. Once they go below zero, you may or may not get an error message. I cover the errors you can get in my guide as well as explain how to use the Repair Hammer to check out the Stability.


#6

but this is nothing to do with repair, i’m trying to use the inverted thatch wedge sloped roof, but it won’t snap.


#7

Would you please upload new images to this board so I can see what’s going on? :arrow_double_up:


#8

This is an ongoing bug, actually. The easiest workaround at the moment is to keep a spare ceiling tile in your hotbar and if you have snapping problems during construction act like you’re going to place the ceiling tile, and when the wireframe is in the correct “snap” position, switch back to the foundation block. This seems to “remind” the game that foundations can be placed there.


#9

I have had the exact same issue. It turned out to be a stability issue with the structure beneath the roof. The bug is that the game was not displaying an error message. Once it was fixed, I got an error message. It is possible that the error was introduced again as the work to optimize the game and make changes to building system.


#10

sorry for late answer.

but the last link i posted was this image

that’s the one with the issue placing the “inverted thatch wedge sloped roof”

the first issue i had was this picture:


#11

Is this in the Live build?


#12

it was on one of the official servers.
but this was before the big patch in april, so it could be that both issue is fixed now.

but i have rented a privat server now and haven’t really tested anything after the big patch, i’m waiting for the full release so i can wipe my server.


#13