Possible bug (question)

Game mode: Single-player
Type of issue: Bug | Other
Server type: Not Applicable
Region: North America
Mods?: No
Edition: Steam


Bug Description:

If connection to Steam or FC Live Services is lost while in game,
can it cause the game to go into a hard freeze? (UE4 stops responding).


Expected Behavior:

No freezing/hang


Steps to Reproduce:

  1. Step 1: While playing SP, the game occasionally hangs with this identified issue in the task manager. (UE Engine Not responding).
  2. Step 2: End process via Task Manager since it can overlap the frozen screen. (only option available if Task Manager can be accessed at all).
    A. IF the end process is successful, the freeze will exit to the desktop and I will find that Steam is still open in the task bar (which is normal).
    Here is the exception:
    Step 3: Even though Steam shows as still open, upon maximizing the Steam window, I notice that Conan Exiles is no longer active. (this has been consistent behavior after a hard freeze).
    What is odd about it is this:
    Usually, on a normal exit through the game menu, CE will still show as still running in Steam and usually take up to 15 seconds to shut down.

When the game has hanged or froze, CE will not show as running in Steam as if it had exited without the normal game exit having been initiated.

That is the reason for this question.
Can a connection loss to Steam or FC Live Services cause the game to go into a hard freeze requiring Task Manager intervention?

Easy to test I suppose. Join the game, play, unplug your internet cable, see what happens.

Generally speaking, considering that single-player can be played offline, continuous fls/steam connection shouldn’t be required as they are only needed for the initial authentication.

1 Like

Since I use a wifi hot spot for internet, I’m left with two primary options.

  1. Unplug the LAN connector to the wifi hot spot
    or
  2. Unplug the power to the wifi hotspot.

I’ll test that.

1 Like

I ran a test by unplugging the LAN connection between the wifi hot spot and my PC.
The game didn’t freeze.
Also, I plugged the LAN connection back in and exited the game the usual way and discovered CE was still running on Steam. Taking the usual amount of time to close.
However, I will run the test again for a longer period next time around. So, I suspect a disconnect really has nothing to do with the random hang / hard freeze.
I suspect something else is going on in the background that is causing this random hang. The thing is that it happens randomly and it doesn’t seem to matter what I’m doing. Either being active or just sitting being inactive.

2 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.