Possible mod error (?)

Hi all!

After 2.8 update hit, my game crashed with a fatal error, and that’s it. No explanation which mod caused that, but I found out that GCAM was the culprit, but the creator fixed it soon after. I could play for 2 days, and fatal error again. On the mod’s steam site, there is no mention to further errors, so I’m helpless.
Does anybody have clue what might cause the problem?
I try on the Savage Wilds discord too (I’m currently on that map, but yesterdays found no info).

There are the log files for additional info - I’s like an alien language for me, but it refers to GCAM in multiple places. I disabled the mod, but still fatal error.

Disabling it means you’ll get even more errors, as the game is trying to load building pieces that no longer exist

1 Like

Is GCAM the only mod on your machine/server? If not, list all of them please so we can eliminate those. You might want to share your mod file in the GCam discord group as well.
https://discord.gg/8awxdGP

After GCAM was updated I stopped getting the ‘Fatality’ message.

1 Like

B:\Programok\Steam\steamapps\workshop\content\440900\1807724172/FogReducer.pak
B:\Programok\Steam\steamapps\workshop\content\440900\1793706840/SevereWeatherV2.pak
B:\Programok\Steam\steamapps\workshop\content\440900\1799016310/StormEx.pak
B:\Programok\Steam\steamapps\workshop\content\440900\1927019439/RebalancedWeather2.pak
B:\Programok\Steam\steamapps\workshop\content\440900\1938352194/CinnamonCandles.pak
B:\Programok\Steam\steamapps\workshop\content\440900\1635257531/DeadlyCreaturesPve.pak
B:\Programok\Steam\steamapps\workshop\content\440900\1701136207/Javelin_Improved.pak
B:\Programok\Steam\steamapps\workshop\content\440900\2235656747/Marty_Hud_Down_Scale_FifoMessages.pak
B:\Programok\Steam\steamapps\workshop\content\440900\1797359985/UIMod_Hosav.pak
B:\Programok\Steam\steamapps\workshop\content\440900\1467634310/Tier4_Thrall_Half_Increased_Spawn.pak
B:\Programok\Steam\steamapps\workshop\content\440900\1579057391/ClayBuildings.pak
B:\Programok\Steam\steamapps\workshop\content\440900\1411872074/Ancient_Architect.pak
B:\Programok\Steam\steamapps\workshop\content\440900\2188497883/LemurianFix.pak
B:\Programok\Steam\steamapps\workshop\content\440900\2377569193/Savage_Wilds.pak
B:\Programok\Steam\steamapps\workshop\content\440900\1702611267/Ishmael_torches_mod.pak
B:\Programok\Steam\steamapps\workshop\content\440900\2015198492/PlantNursery.pak
B:\Programok\Steam\steamapps\workshop\content\440900\2582638583/Stacking_Bleed.pak
B:\Programok\Steam\steamapps\workshop\content\440900\1402835318/Warrior_mutator_mod.pak
B:\Programok\Steam\steamapps\workshop\content\440900\2483184203/Bloodbath.pak
B:\Programok\Steam\steamapps\workshop\content\440900\1699858371/DungeonMasterTools.pak
B:\Programok\Steam\steamapps\workshop\content\440900\1823412793/ModControlPanel.pak
B:\Programok\Steam\steamapps\workshop\content\440900\2617716002/EpicFeasts.pak
B:\Programok\Steam\steamapps\workshop\content\440900\2448526796/EWV.pak
B:\Programok\Steam\steamapps\workshop\content\440900\2618068258/StarEldariumTools.pak
B:\Programok\Steam\steamapps\workshop\content\440900\1890943363/AquilonianPassionBody.pak
B:\Programok\Steam\steamapps\workshop\content\440900\1759544356/SandstormEx.pak
B:\Programok\Steam\steamapps\workshop\content\440900\2715775145/Purge_Thralls_Fixed.pak
B:\Programok\Steam\steamapps\workshop\content\440900\901911361/GCam.pak
B:\Programok\Steam\steamapps\workshop\content\440900\1504284196/GCam_60.pak

@Grymm there is some mod that can be outdated and cause the crash. But why did it take 2 days, and not instantly just like the GCAM :thinking: I was literally around my base expanding it with already placed building pieces.
@Jimbo thanks for the answer, I did not hope that will fix the problem for the same reason what you mentioned, but worth a try.

Quite a few mods there. Depending the mod effects, the game gets the Fatal Crash when your character moves or interacts with somewhere the old mod is active. For example, if GCAM had not been updated, and you had nothing at your spawn point with GCAM items in it (including inside chests). The moment you got within range of an area that had something from GCAM, the server/game would try to reference the GCAM mod, but because GCAM had not been updated to the new Devkit, it would crash out. This will happen with most mods that had not been updated. I cannot comment on any of your other mods as GCAM is the only one in your list my servers use.

You will need to check all your mods to see when they were updated last. Check their change notes and Comments to see if anyone else has issues or whether the modder has left a note. Unfortunately, sometimes the only solution is removing a mod, but many of the most popular mods are kept up to date and why anyone that uses mods is very grateful and supporting to the Mod Designers out there. My opinion is that the core game is made so much better by the modding community.

Hopefully this explains and helps you resolve your crashing issues.

1 Like

Thank you. When GCAM was not updated for 1-2 days, I got close to my base and got the fatal error. I knew that building pieces (lemurian, gcam, warrior mutator and DMT) could be outdated to cause problems, and turned out, GCAM was the one, but got updated soon after it.

Now I’m gonna search all the mods on steam to check the notes/comments, and sorting the outdated ones out one by one. But before that, I will start a new game on the Exiled Lands unmodded to see what happens.

(P.s.: I know I know, I’m a lazy person to cry here instead of unloading the mods and trying them out one by one, I just did not have the time to do it - thanks to the saturday overtime and flat renovating on sundays…)

Edit: case solved, this was not the problem.

1 Like

My friend and I just installed the game, no mods, onto Windows 10 and 11 from GamePass. Seeing fatal errors at launch. Pretty much it. We uninstalled any updates related to the KBs other have mentioned and any updates around the time were the issue started for most users, mid-December. Any ideas?

one

2 Likes

Okay, update:

DungeonMasterTools is the one causing errors. Everything is fine without it. It was updated just a day before game update :rofl:
I lost a good thrall and a top tier weapon + heavy armor set, but I have a backup on my PC, so no big deal.

1 Like

Glad to see you got it all sorted out. :smiley:

1 Like

The mod has an ability to have the followers “emotes”. Not like the 2.8 brought into game, but random, non-selectable stuff, like spitting, yawning, pushups, etc. in a random order. Probably that caused the problem. But why not at the very first moment, when I was with her? :confused:
Whatever, at least I sorted out the mods, I don’t use anyways. Thanks!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.