Possible solution: Problems with thralls not attacking?

Game mode: [Enter game mode here: (Online official | Online private | Single-player)]
Type of issue: [Enter one of the following: Bug | Performance]
Server type: [Enter one of the following: PvE]
Region: EU

[Describe the bug here] Thralls not attacking?

Solution:

How I activate thralls, I first dial the settings before giving them commands. This is how it works for me:

  1. Set ‘Prioritize Melee’
  2. Set ‘Chase Distance’ to maximum
  3. Set ‘Attack Distance’ to maximum
  4. Set ‘Protect Me’

Then it works and I can command thralls to kill any npc. I’ve been leveling up my thralls and never used my weapon. Just point at the npc and use the ‘B’-key (as I set to ‘Attack’) and let them rip.

The set-up on the wheel seems to be necessary before you issue commands. I hope this helps.

1 Like

I had been leveling a thrall and had tried using various options available. I switched from “Guard Me” to “Attack all Enemies” and then back to “Guard Me”. It seemed to work fine for a while and then I got the thrall to level 10. Shortly after that, the thrall stopped attacking. It seemed confused. It sometimes would run to the target, take out the weapon, hesitate, and then run back to me. It sometimes did this several times without attacking the target. I tried the settings above and they had no effect on this problem. I suspect the control data gets corrupted and then the AI does not function correctly.

I started leveling a new thrall and it seems to be working fine for now. However, I would expect that I should be able to change the actions of the thrall for specific circumstances but it seems I cannot. The system gets corrupted and the thrall becomes useless.

3 Likes

Same problem on me, with Thrall from Level 0…

I have a level 20 thrall that does the same thing on occasion and it’s extremely annoying.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.