Possible work around for poor performance...Windows 10 64 bit

Back in March, I put in a report for the game’s stuttering issue. I was asked to make a video and attach it to the report, but when I went to fire the game up again, it would not load. I updated the report with the news that the game suddenly wouldn’t load, but my report got buried with no further assistance.

With the recent patches, I decided to try and fire the game up again. It miraculously loaded. Might have been one of the patches…don’t know, don’t care…it loaded.

Nothing had changed with the game performance issues and stuttering, so I sat here reflecting on all the things I’ve tried on my end to help the situation. The game never really ran smoothly for me except for after the mounts update, but a hotfix shortly after that update negated that progress. So…

As I was moving about the map and looking around with the mouse watching the picture become distorted, I wondered whether mouse smoothing was on or off by default and if changing that setting would help. I located the file that the setting resides in and changed it from “True” to “False” shutting it off. Then, before I closed the window for the game files, I thought, “Ya know what. While I’m in these files, let me try running this in compatibility mode for Windows 7 just for S’s and G’s”. So I did.

I fired the game back up and now it’s running a bit smoother and crisper. The stuttering still exists, but it’s not as frequent or intense as it was. If you have similar issues and want to try this, but don’t know how to do these things, here ya go:

Open your Conan Exiles files…should be along this path if you installed on your C: drive:

C:\Program Files (x86)\Steam\steamapps\common\Conan Exiles

Right click your “ConanSandbox” application in the Conan Exiles folder. Click “Properties”. Click the “Compatibility” tab. Under “Compatibility mode”, check the box “Run this program in compatibility mode for:”, then choose Windows 7 from the drop down menu.

Now, if you want to also try shutting off mouse smoothing, follow this path:

C:\Program Files (x86)\Steam\steamapps\common\Conan Exiles\ConanSandbox\Config

Open the “DefaultInput” file. Find “bEnableMouseSmoothing=True” Change True to False to shut off mouse smoothing.
(Note that after I did this yesterday, CE updated this morning and this setting was reset to default. I had to shut it back off)

These steps didn’t make the game’s performance perfect, but it made a noticeable difference. I don’t know why this helped. I don’t build games, I play them. Maybe someone with more knowledge can offer an explanation of sorts. And if someone wants to bring this to Funcom’s attention, feel free. Maybe it will shed some light on matters for them so they can some day permanently have the game running well for everyone on all platforms, gear, and OS’s.

I was able to repeat this on my sister’s computer. She had the same problems with the game. It helped a bit on her’s too. I feel it might be important to note that we run different systems. Her’s is AMD based, mine’s Intel based. The only thing our rigs have in common is they both run Windows 10 64 bit and they both have GeForce graphics cards. I have a friend with the same game issues who has an AMD based system and video card. I’ll be sharing this with him when he gets back from his weekend trip to see if it helps on his system as well.

I’ve been running the game for one day since these changes have been made, but I don’t see why this work around wouldn’t continue to work unless another update, patch, of hotfix botches it up.

I hope someone finds this information useful and helpful. Good luck.

6 Likes

Oh…I forgot to mention that since I implemented these changes, my GPU runs several degrees cooler and there’s not as much GPU usage. Yeah…it’s got me scratching my head. Can anyone explain that?

From my understanding. Mouse smoothing requires the game to run at a steady framerate. So it does a sort of v-sync, but instead of syncing up with the monitor, it tries to figure the average framerate and stick to that in order to make things look smoother.

Jittering 30 to 60 FPS looks worse than a steady 38DPS for example.

Anyway this requires a bit more oomph on the hardware to pull off, which degrades performance. And that performance hit might be causing the stuttering. As it tries to sync things up with the mouse, but fails, and it picks up where it can be stable again, lurching forward in displayed frames.

I’m no more an expert in this stuff than many others. But this is my educated guess and theory to what you’re seeing here. As to why compatibility mode works, I assume there’s overhead in Win10 that isn’t applied in Win7. Again a guess.

With this said, you’ve done an excellent job figuring this all out through deduction. I’d imagine this might actually help the devs nail down some of these issues. Great job.

1 Like

Hooked up my buddy with the AMD system and vid card. Made a difference on his too. Like with mine, his stutters less and it’s not perfect, but clearly a step in the right direction. :slight_smile:

Hmmm… Then maybe just cut your frame rate in game settings? I have rather old monitors on new graphic card so I cut my frame rate to 60 FPS to match them and I don’t have such problems.

I have no means of testing that. I personally don’t see the stuttering problem on my machine. But I’m kinda brute forcing the game with an overpowered machine to begin with.

Your idea might work for others. I know it sounds crazy but some may consider cutting their FPS to 30 ( I think you can go this low). If its stable, that would easily be playable. As long as its stable. If its dipping below occasionally, you will notice.

1 Like