Primary Weapon Energy Not Showing Up

I have multiple characters for Secret World Legends and had no issues with any of them until recently and this is a bug I just can’t figure out or find a workaround for.

On my Templar Mercenary character (nickname “NanCorbin”), the primary weapon energy doesn’t show up but the secondary one does. Screenshots are available on request but unfortunately the forum rules say new users can’t upload screenshots. It doesn’t matter what I put in the primary weapon slot, its energy and special meter doesn’t show up.

Bug Testing Steps Taken

  1. Swap primary (rifle) and secondary (fist) weapon - Rifle energy bar and grenade meter showed up as expected in secondary weapon energy area of hud, but Fist energy bar and rage meter do not display.

  2. Load into new area - Secondary weapon energy meter shows up as expected but primary does not.

  3. Die and resurrect - Secondary weapon energy meter shows up but primary does not.

  4. Use different weapon set - Replaced primary weapon (rifle) with Chaos weapon, in primary slot, but primary weapon energy indicator still not showing up.

  5. Log into a different character - Cycled through all of the other characters of mine. All characters display both primary and secondary weapon energy meters. NanCorbin is the only one with the glitch.

  6. Exit game completely and re-log in - Secondary energy meter displays as expected but primary energy meter does not.

  7. Continue Kingsmouth story through “Horror Show” step - Secondary meter displays as expected but primary energy meter does not.

  8. Create new Templar Mercenary character - Primary energy meter and secondary energy meter both display as expected.

Game has no mods. I’m just running the base game, and it’s not across all of my characters or even limited to a single class/faction combo. I’m tearing my hair out since I don’t want to lose some of the goodies I picked up as Nan. She’s a starter character, but I’ve been grabbing the second anniversary gifts and don’t want to lose them.

It sounds like the energy bar has been moved - try clicking the little padlock at the top right of the screen and moving stuff around to see if you can uncover it.

Didn’t expect a reply so soon!

I did what you said and moved around everything, but the primary weapon energy slot was apparently somehow removed from the UI elements. (How in the heck did that happen?!)

I did manage to fix the problem based on your suggestion by going to Settings > Interface Options and clicking the DEFAULT button at the bottom. That reset the interface and brought back my primary energy bar.

Thank you so much for your suggestion!

1 Like

there are actually options as to whether or not to show the energy or specials bars for each weapon under interface options, I believe, so they might have gotten unchecked for that character…

Welcome back, @Cybra! I’m glad to see you got your problem resolved quickly! Closing the report.