Private Server Bugs - No mods enabled

Game mode: [Online Private] Public Unofficial.
Type of issue: [Bug]
Server type: [PvP]
Region: [USA-East]


Server has no mods, and was just created 3-4 weeks ago. Restarts daily. Hosted by g-portal.

Starmetal nodes won’t crack/explode open. Even after trying with 4-5 explosive jars. Multiple starmetal nodes tried by multiple players. No luck exploding.

Building peices won’t always snap. Usually the roofing corners. Will just say placement invalid, or won’t have a snap-point at all.

Glitch with single-handed items to were you can’t equipt any single-handed item. It will auto de-equipt. Only fix so far has been to equipt a 2-handed weapon. Death doesn’t fix it, neither does relogging.

Wells dont refill after server restart. Happens with both small, and large wells. Once you drink from it and empty it/dry it up once then the server restarts, the well no longer fills up.


Starmetal as far as I know isn’t a known bug, most servers seem to be having no troubles with this. Some more testing and reporting back might be good if there is indeed an issue you have found!

Building snapping is often due to a stability issue. Throw down some extra stability, or check with your repair hammer. Another trick is to quickly swap to another building piece and back and fourth a couple of times.

No idea about the single-handed

Wells is very known bug, community team have commented on it several times. It’s a complicated issue to say the least.

I thought the whole starmetal thing was fixed, but recently I got it reported to me that people were having issues with it on my servers, so I checked it myself, restarted the server to make sure then researched the issue. Seems that starmetal is still an issue according to recent posts from google showing posted 1-2 weeks ago.

Also, I have tried pillars and everything else you just listed before posting this and still get the issue. With the size of the structure in general it shouldn’t need any as its just a 4x4 with a pointed roof but it won’t allow for the entire roof the be completed.

Let’s just say corner pieces of all sorts are problematic at the moment. Try placing corner stair pieces, especially anything other than the basic sandstone, and it’s just Russian Roulette. Some roofing pieces seem to be behaving the same way.

The problems I have been having with parts not snapping in have been corrected by either loading a different type of building part then going back to one with trouble or logging back to main menu and coming back in the game.
The latter seems to be the most common fix for me.
~ :bear:

@Tascha

Any ideas if these bugs are known or if a patch is being released soon for them?

These are all known bugs yeah. I would label them C-Bugs (which means we know about them but they are not highest priority right now, even though we just made a list with C-Bugs that are being brought up a lot and are frustrating for players. So we can look into them to be considered to be fixed despite having higher priority issues to work on as well.)