Private server / Client mismatch after updating 15/5 patch


#1

Hi!
Trying to join our dedicated server after updating the game-client.
Obviously the game called it a client mismatch and would not let me connect.
However after updating the server accordingly

“Launch the steamcmd executable.
Once that load there’s a Steam> prompt.
Type: login anonymous
app_update 443030
type “exit” to leave SteamCMD.”

I still get the same error “The match you are trying to join is running an incompatible version of the game. Please try upgrading your game version.”

Anyone got news on what the problem might be?


#2

Update
We tried doing a new clean install of the server in a different directory, it worked out well and it was fine to connect to it. Unfortunately our database/world is still on the actual server(Old one), so I guess we will try to figure out a way to move the world to the new server directory or figure out how to actually update the main server properly.

All tips are welcome!


#3

Have you updated both Server and clients?