PS4 list of bugs after 1.80 update

Basic Info:

Platform: Playstation 4
Issue Type: Gameplay
Game Mode: Single Player
Server Type: PvE
Server Name: N/A

. Tree leeves are still invisible (ex: pine trees, specially around beaches in Siptah) - happens: always
. Bushes and grass are still invisible (same region as above) - happens: always
. Lag loading textures (sometimes textures take 3-5 seconds to load) - happens: always (got worse in 1.80)
. Framerate issues - happens: randomly, but quite often (both on LAN & Wireless connection - got worse in 1.80)
. Flickering shadows on trees/certain objects (example: dry wood trees) - happens: randomly, specially at distance
. Quality/Performance Graphics option on settings is now gone - happens: always
. Picking up a worktable or storing box destroys it (instead of going into inventory) - happens: always (workaround so far is to use “move” instead)
. Textures appearing only on a proximity of around 3 meters (ex: horse, armor textures) - happens: randomly, quite often
. Character face textures lost definition & color tones (specially noticeable on thick beards) - happens: always (when also grass and trees are gone)
. Sky textures, shadows seem to be on low-res or completely gone (ex: Maelstrom smoke is practically gone) - happens: randomly (specially on beach areas in Siptah)
. Game takes 10x more time to load - happens: always (got worse after 1.80)
. Inventory use or workstation use seems to be slower now displaying objects - happens: randomly (got worse after 1.80)

PS4 PRO 1.80 patch - 6+ hours of playing - LAN connection


On siptah the maelstrom enemys stay after the storm (including bosses makes this a positiv bug)

0 grit for placed pets is a bug for me too


Can no longer consume raw meat - always
Disconnecting from server frequently (roughly every half hour) -alwayd
Previous DLC armor and building pieces completely invisible or partially -always

1 Like

Southwestern part of Siptah seems almost normal.
I died and had a bedroll there, when spawning all the trees, grass, sky and even face textures looked normal (thick beard had lost color tones and definition)
Except for some camp objects, all the textures were there.
Then I ran north to my base and it remained normal. When entering my base and then coming out everything was screwed up again, with trees without textures, no grass, etc (i guess leaving the base resets the textures outside).

Hello there @Draltar,

Thank you for taking the time to reach out to us and for the detailed bug report.

We have released a new patch since you posted this (patch notes can be found here), however, I am wondering if you’re still experiencing some of these situations, if so, could you please get back to me with which ones are still occurring?

Yes, I know there is a patch and it was installed yesterday.
All the issues described are after the patch 1.80 / 3.01 (I edited the post with the persistent issues).

I played the game over 5 hours after the patch installed and all the issues I posted are still happening.

The only thing the patch solved was the DLC items not being displayed (armor, workstations, etc) and some graphic glitches (like wheel of pain not being shown or invisible enemies).

All the rest, the longer time to load, texture issues loading, framerate, missing trees and grass, overall performance issues are still there, including the pick up object destroying items instead of going into inventory (boxes, workstations, feed crates, etc).

Playing on a PS4 PRO - Single player


I can agree, all issues are there after 3.01 patch.


Yes. Have same problem on PS4. Event after instaling lasy patch, textures, hyenas, bushes and tree leafs are still invisible.

1 Like

Just waited 15 minutes for the game to start (2nd try) - measured when the bar is loading…

Noticed all the same even after update 3.01.

Would also add…

  • On screen Messages such as ’ entertained’, ‘losing corruption’ cause small fps hitches…

Whether that’s tied to the message itself or the Performer thrall I don’t know

Crashing while swimming result in a death under water, respawn with 0 stamina and hp bar shows 200/0 ( no max health) relog solve the problem. One crash in water is a serious time spent in loading screens

I’m having most of these issues after the patch as well. The biggest is my game keeps freezing randomly, whether I’m out exploring or at my base. Only way to fix it is to manually close the game and reload. Throughout today, there was several hours where I couldn’t load in at all.

In regards to your note about the storage boxes/benches being destroyed, that is by design. If you pick them up, the materials are returned to you and you have to use the build hammer to place them again.


Good stuff hot fix only fixed invisible stuff game still pretty unplayable especially in pvp

Just adding another voice to the continuing slow render, lagging, crashes, and especially freezes.
Using both a PS5 and PS4 with SSD enhancement.
Worse in single player than on private servers.

The invisiblity of assets was corrected by the patch. But that’s about all.

Also, the Bazaar has an inaccurate item.
Sandstone set 2 does not give the purchaser the items shown. Either the display is in error or there is a bug preventing the addition of the piece.

1 Like

A awful lot of problens like being killed every time using the obelisk because the character spaws and becomes vulnerable way before I got control over his to avoid enemies, also a disturbin lot of lag and disconnections, making impossible to enjoy the game, sinsce 90% of deaths are not player falt

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.