Purge Defender - Journey Broken - Convert a Purge Thrall step incompletable

I play on Official Server #1500, on the Exiles Lands map, and I am a level 60 character. I knew we were close to getting a purge event, so I activated the Purge Defender, Journey. Yesterday a purge triggered, and during the purge I knocked out a Tier 4 Blacksmith, and placed him on a Greater Wheel of Pain.

Doing these actions, completed the following journey steps:

  • Trigger a Purge
  • Knock out a Purge Enemy
  • Complete a Purge

Today, the thrall training on the wheel was complete. I claimed the thrall (Master Blacksmith Ulfric) and placed him on a Garrison Blacksmith Bench. None of these actions completed the final step: Convert a Purge Thrall

I can’t find much information online about this, however I did find one Reddit thread where someone said it worked for them when they placed the knocked out purge thrall on the wheel, after the purge completed. There are many people that have had this issue, however there is a belief that this journey step can only be completed by placing a Tier 4 thrall on the wheel (which is what I did).

Is this a known bug, or does anyone know what can be done to resolve this?

1 Like

Had this happen the other day with a generic T1 Exile. I assumed you needed a named thrall. Your topic seems to confirm my suspicions. Unless there’s more to it. I took it out though when it didn’t trigger. However, the horse one didn’t work until I pulled the horse out when it finished. Maybe wait until he’s done and see if it works? I know none of the thrall ones required that, but maybe it’s like the outrider horse step?

Edit… my bad, I missed the beginning where you said it was already done. Then idk. Might be one of the many journey bugs.

So, this one irritated me.

  1. Knock out a purge thrall, even a T1, DO NOT put them on the wheel

  2. Complete the purge

  3. Find knocked out thrall, put them on the wheel

The way it’s currently structured makes zero sense as step 3 and step 2 should be reversed, but, this is the solution.

1 Like

Thanks Kor - I did the purge last night - loaded a T4 thrall in the wheel but the purge didnt complete until i killed the rest of the thralls. Pulled the T4 out of the wheel this morning and no completed journey step. I will try your suggestion next time.

1 Like

I mean Pugilist - thx

1 Like

I did this on mine since I had no wheel in the area (the purge spawned on a generic map room by an obelisk). It didn’t work. I had to go through a map room, so idk if that makes a difference.

I done this last night,It popped immediately as i put the thrall in the wheel.I was concerned because the overlord journey is stuck on place a competent crafter.

1 Like

I bet it doesn’t even have to be a thrall from the purge but sny old npc you drag to the wheel after you completed all the other steps

Good evening .
I had this problem. Step 1 and 2 we were validated but Step 3 “Surviving a purge” was not worked.
I therefore expected the following purge and when it is able to to finish, I put the NPC in the wheel. Unfortunately at the end of the cycle the step 4 was not validated.
I try Vias the administrator panel to appear a purge NPC without result.
The problem knows how to resolve itself to the third purge

It would seem to me that this is like a few of the other journey steps… they unlock for some and not for others. Wow… talk about inconsistent. :expressionless:

1 Like

Because CE is in fact a bunch of different games masquerading as one - there is single player version, a modded single player version, multiplayer version, modded multiplayer version and also a console variants.

I have recently tested this Purge journey in single player (with UI mods) - all steps worked like a breeze.

It’s sad… it’s literally my last journey to complete on the EL map.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.