Quick way to improve graphics (Steam/old engine)

I’d try the new engine.

I know for the majority of people it’s not working, but I’ve got this…

…and it can’t or the life of it seem to run its MX940 with the old engine properly. The frame rates are below 20fps with the old engine, and while it’s pretty clear the new engine has some issues with the Nvidia card, instead of 20fps in Old Athen with the old engine I get 30-40 fps in Old Athen with the new engine. Maybe a bit more, because the old engine seems a bit like trying to dance in treacle on the old engine.

That said, the new engine will, for me, crash occasionally wherever there are whompa effects/textures to load.

It also loads pretty spiffily. I’ll sometimes in cities and SL temples watch walls and items load into existence after zoning while I’m happily running around (this is probably more down to having single channel RAM due to waiting out memory pricing/not really caring much.)

This is also what my options look like after mucking about with @Caloss2’s suggested Nvidia shenanigans. I can assure you, it’s my dedicated card working with these settings. It gets agitated, hot and bothered.

1 Like

That seems very strange you get 20fps on the old engine. I find its easy to run on just about any computer these days. Do you have Vsync enabled? AO with Vsync is horrible.

If you’re still getting low framerates, try lowering your view distance

It seems. No Vsync involved and all the old tricks, etc. I just spent a while messing with the old engine (reinstall), which after setting profiles and messing with other settings left me with the conclusion that the graphics card just doesn’t want to co-operate with the old engine.

:man_shrugging:

Primary display driver is the on-die intel GPU. Not your nvidia GPU.
Use the nvidia inspector add AO to something like 3dmark 2004; scroll down until you find “enable for optimus” and enable it. Dual graphics systems coding in windows will choose that AO is not a 3d application every time until you tell it otherwise.

If it’s

0x00000001 SHIM_RENDERING_MODE_ENABLE

then it’s already that way from when I set the profiles way back when. :confused:

0x0000011 (Autodesk showcase, monster hunter online … etc

1 Like

Oops. Yes, I see now. It gave the new engine a tiny boost (perhaps), but the old engine still doesn’t grok it. With that said, I’ll stop trying to wrap my head around the old engine for the sake of everyone’s sanity. Several reboots after changed profile options, a clean install of graphics drivers (Display Driver Uninstaller and the whole dance) and setting the discrete card as the default global graphics card didn’t seem to work, so thanks to both of you, but oh well. :slight_smile:

Edit:

I haven’t crashed once after you corrected me on the Optimus setting. Gg!

I did this but im not seeing the 0x000011 entry, it’s just a blank space in that spot between 0x000010 and 0x000012

Also I’m trying this on the old engine with a laptop with a 1050Ti, I guess it wont work with the old?

Yeah pretty sure that’s only for the new engine but I could be wrong

tried forced aa with an nvidia card a while back. i remember it killing my framerate, especially if multiboxing.

Vsync enabled or no Vsync?

Bumping cus more players should be aware of this.

1 Like

amazing post. it helped alot. BUMP

You can edit the files regarding whompas entirely and zone to icc in about .3s with no crashing.
I’ll see if I can retrieve the steps necessary, I had a video made about it on my old HDD.

1 Like

Bump

Bump

I found a program from some youtube poster called dgvoodoo2 - I had the same issue as you before and this install fixed it for me.

Worth a shot.

Fc should do this then as an official fix then.

can u explain it ? … Tried it but cant find any solutions

may this be also a way to fix the new client when u got stucked on low res textures !?

bump and thanks, i need to check on this or i will rip my head of while running at icc :rage: