Rescued Thralls Won't Equip/Use Weapon - Siptah

Game mode: Online private
Type of issue: Bug
Server type: PvE
Region: NA
Mods?: Yes

Edition: Steam

Bug Description:

Rescue a thrall from a cage on Siptah and they will only punch when attacking. This was a problem a while back and I thought it was fixed. Recently started playing on Siptah again and the problem is still there, or has returned.

They also spawn with sacs in their inventory with attack animation names like xxmelee_right or something like that.

I’ve tried rescuing multiple thralls, about 6 or 7 now. Tried putting the weapon directly in their hand. Tried giving them different weapons.

So far I have only rescued bearer thralls of different varieties. So I am not sure if other types of thralls have the issue or if it is specific to bearers.

Installed Mods:

modlist.txt (2.1 KB)

Steps to Reproduce:

  1. Rescue a thrall
  2. Go into battle with the rescued thrall while they have a weapon equipped either in their inventory or directly in their hands

I’ve found that after a server restart, rescued thralls will attack with their weapon again. It’s the first time I’ve tried this because usually I get them killed within the first 5 minutes haha.

I’m seeing this as well. Any caged thrall that is rescued won’t equip the weapon in their inventory. Thralls that are captured and put through the “wheel of friendship” don’t have this issue.

They will draw their weapon momentarily if you also draw your weapon, but they won’t actually attack anything with it, instead always using their fists…

edit: After restarting the server (well, this was single player, so just restarting the game), the thrall indeed does use a weapon, but any thrall rescued during the current session still refuses to fight with weapons.

Seeing thisb issue as well.
Siptah, official PvP, NA, caged released thralls not equipping any weapon.

I will check if imine f8xes like this as well tomorrow. Got 3 thralls today, 2 died, because well fists vs sword is no win for T2 bearers. The T3 I got has good health and I have it on 30m follow, no attack to stay out of fights :slight_smile:

So I rescued a Black Corsair Fighter 2 today and it spawned in with a 1h axe and didn’t have an issue with attacking with the axe.

It seems so far it is just bearers that spawn with a 1h sword. That seems to be the pattern for me at least.

I’m on Xbox and this is happening as well I restart game and see if that helps my single players game

Can I get names of the Thralls people are seeing this happen with? Appears to be consistently reported that its related to bearers, but which ones?


Although just now relogging in for the 3rd time has fixed him.

So 15 levels of play-time and he never pulled any weapon.

Rescued from a jailor cage.

Not just rescued, I have a Luba (dancer) and a Featherstep (bearer) for half a year, and both of them use their fitsts after update. Before that, they used any weapon I gave them. If I manually equip them with a weapon, they just get REALLY close to the enemies and stare at them.

Cimmerian Bearer III
Zamorian Bearer II
Zingaran Bearer I
Hyborian Bearer I

All of these were rescued from cages on Siptah and would not attack. They all also spawn with a 1h iron sword and sometimes an iron mace (I think).

I had a bearer and a Stygian fighter 3 have it happen.
The bearer had a 1h mace.
Stygian had a shield and 1h sword.

bearer worked after server restart.
Will check the Stygian Fighter 3 today.

I’ve seen it with any bearer (tier 1,2,3, any race) I’ve rescued, as well as with any exile (tier 1,2,3, any race).
I also had a tier 4 rescued fighter that had the issue, though I don’t recall which fighter it was.
Haven’t seen many other rescues lately, so I can’t confirm or deny whether other fighters/archers have this issue.

Fighter worked after restart as well.
Makes me think the weapon AI data for rescued thralls is not loading at time of resume, then resets after server start.

1 Like

Can confirm I have the same issue…

I can confirm rescued thralls will not use weapons until after a server reset. On several occasions I’ve forgotten this and the server crashed right after the thrall would have first attacked.

Please fix this as I’m old and forgetful and may crash the server again.

Hello everyone, thank you for reporting this issue. We’re already aware of this and it’s going to be addressed in a future update!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.