Server Crashing and Fatal Errors

Evening All,

So I’m the Sweet yet Badass Admin on The Perils of Power. You may know it better for @TheRedKing76 Server XD.

But anyways, since the update and the Modders going nuts to fix everything, The server to date is well up to date.

Yet we still cant gain access or stay logged in for more then a few minutes at a time.
Ive loving read through my Logs and found many mods are throwing up this kind of error:-

[2021.12.12-15.47.06:356][909]LogPakFile:Warning: Attempted to load forbidden filename: “…/…/…/ConanSandbox/Content/Environment/Player_built/Meshes/SK_tier3_vault.uasset”
[2021.12.12-15.47.06:356][909]LogStreaming:Error: Couldn’t find file for package /Game/Environment/Player_built/Meshes/SK_tier3_vault requested by async loading code. NameToLoad: /Game/Environment/Player_built/Meshes/SK_tier3_vault
[2021.12.12-15.47.06:356][909]LogStreaming:Error: Found 1 dependent packages…
[2021.12.12-15.47.06:356][909]LogStreaming:Error: /Game/Mods/DungeonMasterTools/Blueprints2/BP_PL_Chest_Vaultmini

Im seeing almost all the Mods throwing this kind of error over one thing or another.
Checked to ensure My mods are up to date.
Checked to ensure the Server Mod list is up to date.

Mod Discords say they are fine and working.

So the issue here is…
Has Conan been borked by Funcom?
Do the Modders need to go over everything… again?
Or is this Server Host (GePortal) side?

Any ideas or you know whats up let me know!
Thanks ^^

Whenever you have a modded server/game and have this sort of issue. Just go ahead and give the modlist, because that’s the first thing that’s going to be asked for.

And in this case, the only way for us to tell you what your issue is.

No they added a few new features, which means blueprints need to be updated.

No, if they’re using child blueprints, they likely just need to rebuild, reupload. If they’re overwriting, then maybe. Otherwise they should be fine. This is problematic when using mods by authors who have retired.

G-Portal? I recommend using another host ASAP. They are notoriously bad for modded servers. But I don’t think they are causing the fatal error issue. Its usually when trying to update mods is when they go crappy in this side of things.

But yeah, give us the modlist and we can probably tell you exactly what mod is causing the issue or likely causing it.

I believe this is the Order:-
(Red King was talking about switching a few around.

Pippi - User & Server Management
Emberlight
Dude’s Delightful Decorations
Dude’s Delightful Decorations Deux
IMMERSE RP: Placeables Decor
IMMERSE RP: Fright Night
IMMERSE RP: Festive Days
Shanis Stuff
Lotus Cooking & Brewing
Crucial Decorations
MSCasaDesFlores
Dark Desires (Please note: version by Amrita/NOT by Maggie)
Roleplay Redux
Northern Timber
DungeonMasterTools
Extended Mounts
Barbarian Barber
RA: Character Customisation
Immersive Armor
Fashionist (DLC Compatible)
Better Thralls
The Darkwoods (Please Note: version by Kyeri/NOT by SOLU7ION)
Friiezy’s Mod
RPVillageAddOn
Endgame Extended Weapon Arsenal (EEWA)
Less Building Placement Restrictions
Kerozards Paragon Leveling - A Multigun Refresh
Hosav’s Custom UI Mod - Revamped!
Expanded Map - Curse Wall Removal (Please Note: version by Kyeri/NOT by SOLU7ION) (edited)

Unsure if he removed the Curse Wall yet as its now built into Darkwoods.

Well I can say that Pippi, Dude’s Mods, Dark Desires, Roleplay Redux, Barbarian Barber, RA Character Customization, Immersive Armor, Fashionist, LBPR, and Hosav’s UI are all not causing your issue.

Its gonna be one of the others. Here’s how you can narrow it down however. Look at all of the mods you are subscribed to and check to see which ones haven’t been updated since December 8th.

Next you can load those up in Singleplayer one by one till you find the ones that cause crashes, and then you have your culprits.

Oooff this is going to be a while…

Alright I’ll give it a go and hope one throws a fit.

Thank you ^^

I weeded out the ‘out of date’ Mods - 7 in total and all work fine in single player.

All I can say, these mods listed below are working fine.

image
EDIT: Savage Steel 1 and 2 has been fixed since the original posting.

Mods I know for sure aren’t working at the moment:
Cathedrals
Stun Bows

Although haven’t tested the Simple Archery Overhaul mod (but has not crashed the server or Single Player when online).

I am still doing tests so may find other issues later.

1 Like

Yeah, we’ve been going through every usual channel to try and figure this one out. We don’t usually post about server issues as they usually fix themselves or I find the solution but this one has really got us stumped good.

Hmm I’m starting to wonder if the Order list has something to do with it.
In Single player loading them up in a hap hazard order, all mods work fine together.

I was wondering about load order myself. While it’s obviously worked up until now, perhaps something with the update has rearranged something and we need a minor rearrange. I’ll try almost anything at this point :smiley:

That is always possible.

Typically I follow the Multigun mod load concept.

Personally on top of his concept, I do (minus any mod that has mod load order requirments)

Pippi
Building Mods
Placeables Mods
Gear Mods
Map Expansion Mods
Admin/Feature Mods
AST mod
New map Mod

I think Pythagoras Support Beams and LBPR - Additional Features may be the only exceptions on following the personal setup above.

Well here goes to a re-order of the Mods fingers crossed

Yeah, it was Multigun’s initial placement list I used to put it all together. So you’re saying put the building mods closer to the top? Can certainly give that a try. As I said, the order has been working just fine but since there’s really no definitive list for mod placements, I suppose it can always be rearranged. Never tried once I got them working in the first place lol.

Its what I do, not really necessary but it has been working for years so I tend not to mess what is working . lol.

Confirmed Thrall Side Kick is working and Archery Overhaul as well. I think I did enough testing this week.

That’s been most of my night and now we’re going into today lol. Always a party here :joy:

Update: Still no success. Removed a few mods that were ‘out of date’ and started rearranging the mod order but to no avail. It is very strange as it doesn’t effect finding or joining the server; I can get into the game every time. As soon as you attempt to move around, however, that’s when the fatal occurs. Usually when a mod causes issue, I just can’t get into the server but I can get in no problem. I’m also assuming it has to be a mod issue of some kind as it also effects the offline, single player game.

Well, back to the grindstone.

I am sure one of the mods on that list you have is broken at the moment (beyond the ones I have working on my servers - which were noted above).

I would check mods I do not have such as RPVillageAddOn, ImmersiveArmor, Roleplay Redux, etc. since I do know their status.

We only have a small amount of mods left that haven’t updated. I’ll test two of them here soon; Fashionist and Better Thralls. If those aren’t it, that would just leave…

  • IMMERSE (Placeables Decor, Fright Night and Festive Days), though these have never been an issue, even after not updating for quite some time. Really hope it isn’t one of these as they do add a lot of beauty :smiley:
  • Hosav’s Custom UI Mod, but I’d be hard pressed to think one of Hosav’s is the problem.
  • Roleplay Redux, though no one in their Discord has voiced any complaints.
  • Barbarian Barber, I already tried removing this one earlier with no luck.

I’ll keep trying until I figure this @#$ thing out or so help me…no, really, help me :joy:

And thank you for trying. There’s a reason I stay on this forum and this is one reason why.

Do a database check.

Save a copy of your game.db or rename it and load the server with a fresh db and see if you get any crashes.