Single Player Purge Not Occuring

Single Player

Unable to get purge to occur. Stuck in Journey and want to experience purge.
88 Hours of Gameplay; Level 53. Purge Meter has been at FULL. I have tried tweaking the admin settings to increase purge frequency and point threshold. Minimum amount of players set to 0. I have done a full uninstall and reinstall last night. I have a large enclosed structure with my bed in it. My building stations are all around that enclosed structure on the Ground. Everything is built at H5 on the map with 20+ Thralls. Is there still bugs with purges occuring in single player? Or is it some setting I am missing?

Could you provide the exact location? If you don’t know how to do that, move your character to the lowest floor of your base, stand in the center of the building, and press:
Ctrl + Shift + Alt + L
That should pop up something on the screen that gives you a message you can copy to clipboard that looks like “TeleportPlayer XX.xx YY.yy ZZ.zz”
I’ll test and see if I can get a purge to occur there on my Singleplayer game. Some places do have trouble with the purge not happening correctly, unfortunately. If that location is the problem, you could perhaps build another structure in a location that does work only for long enough to start a purge.

1 Like

Thanks for assisting.

TeleportPlayer 29163.691406 214759.84375 -19879.875

I checked the purge map on the wiki and although it isn’t directly over the red swords; it should be within the radius. I tried what others suggested and made a few bases to test out if it was location based but still no purge activates.

1 Like

Purge Testing. Live Client. Singleplayer Mode.

TL;DR - Purge was successful with no anomalies observed

This purge test was performed using the designs and methodology consistent with my previous purge tests. The building location was as close as possible to the location given by @onlymrmime above and coordinates of the final structure are:
TeleportPlayer 29139.162109 214674.25 -19645.798828
I both filled my Purge Meter and successfully triggered a Purge with admin commands. The Purge that spawned in was the Horde of Darfari Cannibals. I did not need to interfere with the first wave, and all subsequent waves followed naturally with no need for admin intervention. There were approximately 6 distinct waves and after the final wave, the game reported that the Horde of Darfari Cannibals had been defeated and subsequently awarded me with the Journey Step for surviving a Purge. Having successfully completed the test, I didn’t feel it necessary to trigger another purge, but I can do so if necessary (with actual screencaps). The screencaps below show some of the event log entries and the building’s design and location.

I thought I had some quality screencaps using the Steam in-game overlay screenshot function, but that turned out to be a big pile of disappointment with no image files whatsoever. So unfortunately, we’ll have to settle for a few after-the-fact screencaps taken the old fashioned way to give some context.


Does your event log show anything purge-related? You can follow the example in my screencap to help display this for you. Press ESC to open the in-game menu and one of the options is Event Log. Open that, and set the distance to maximum, set the time to maximum, select the purge checkbox, unselect all other checkboxes, then click submit. It should give you a report IF there are any entries to display.

is it a sandstone one?


It was a mixture of sandstone and reinforced stone. After trying it again today - it worked. The only thing different from my first post was restarting my server after adjusting purge settings in the menu. Upon restart I tried inputting the admin commands of emptying my purge meter, filling my purge meter, and then startplayerpurge. The intiation of the purge began shortly after. I checked the logs according to bbtech and i saw that the purge initiated before my last server shutdown too. But i didn’t see a notification. Before that server shutdown I moved my bed from a small enclosed shack which was barely separated from my more established complex… Perhaps those two buildings so close together confused the purge checks? Don’t really know what worked. But it finally triggered so thank you to everyone


Honestly the purge system is probably such a complicated section of code that it’s hard to say for sure what sorts of factors are involved. And I think I remember someone mentioning that it’s proprietary and/or can’t even be viewed with the Devkit or something along those lines. So really any time one of us tries to help troubleshoot or describe details about the purge, we’re just giving our best guess based on our personal experiences and the collective anecdotal reports of others. Glad you got it working, even if you did have to use admin commands.

1 Like

It does take some minutes once the server decides a purge has started until the player is notified. I’m not sure why that happens.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.