Siptah artisan items not showing

On xbox official server 7111 i learned the eldarium chest and braziers. Learned all the vault statues and sigils and none of them are showing up in the artisan table. It was there this whole time now today it’s all gone.

1 Like

I’m on ps4 last week could not find recipes in benches tried scrolling through the different dlcs types still no love :cry: ended up logging in and out a couple times fixed it. Hopefully this will help. Welcome to the Forum.

Thank you i tried that multiple times and a different xbox still no luck

1 Like

Did you check if any filters are active?

1 Like

Yes i did

1 Like

Sorry to hear that hopefully 3.0 update may help. @Community any suggestions other than making a Zendesk report?

@Funcom_Community this still isn’t working and no one has responded to my bug report on zendesk


Thank you for reaching out to us. We’ll reach out to you in private to request more information on this issue.

Please check your notifications for the direct message we’ll send you.