Smelter thralls don't work - PC


#1

Platform: PC
Game mode: g-portal server
Version: 94750/17645 (can be read from bottom right on main menu, or at the bottom of the ingame menu)
Problem: Bug

The problem I have been encountering is Smelter Thralls do not work. Other thralls appear to be working okay.

Repro steps:

  1. Tried smelting without Smelter III & Yael of Shem (Stone 10:1 - Ironstone 5:1)
  2. Tried smelting with Smelter III & Yael of Shem (Still Stone 10:1 - Ironstone 5:1)

#2

They still speed up the furnace times they just don’t lower mat cost right now. But can confirm minus faster times for making bricks or bars, they do nothing else.


#3

At least the armorer and blacksmith thralls reduce the material costs of well armor and weapons.


#4

As far as I’m aware, Smelters, Tanners and Cooks do not have a mat reduce cost when used in furnaces, tanneries, and Campfires. Instead, they increase speed, and reduce fuel consumption.


#5

I can live with that realism for those crafting stations. As long as the armorer and blacksmiths do reduce the mat costs. How about the Master Crafter at the Artisan table?


#6

Yes. Carpenters reduce costs at the Artisan table. I’ve tested that one myself making vaults.


#7

There is one master crafter available for that table but I wasn’t aware that you could use carpenters for that, hmmm


#8

Armorer’s reduce costs at the artisan’s table, too. I imagine more crafter types do too.


#9

I will have to try those thralls


#10