[Solved] Could not connect to server Authentication Failed

**Game mode:**Online Private
Type of issue: Bug
Server type: Any
Region: NA


I am a server admin and had a user who kept getting the [Could not connect to server Authentication Failed] error. After a considerable amount of time and research we found out that it was due to her steam user name. Her steam user name just had a single non-letter/number character and as i’ve seen with some games this sometimes gets reported to the game as ??? for the steam name. The problem that this appears to cause is that Conan exiles login system use ? as a separator in the login line. At least it appears in the log that way.

Other UE4 games don’t have this issue so I’m assuming this is some quirk with how conan was coded for that portion. She changed her name to just a letter name and immediately was able to get in.

I don’t know if this has been previously reported/solved but NO google search links to the funcom forums related to that error mention steam name as a issue. Perhaps updating the pinned tech issues and having mods add the possible solve to the existing, now LOCKED threads, could.

Also as a point of contention by locking threads after a certain time that are not solved properly u prevent future solves from being posted. This is a bad management decision in my opinion and leads to frustration.


Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:
1.
2.
3.
4.

1 Like

Hello @KaraGeek, welcome to the forums!

We appreciate that you took the time to share this issue and your feedback with us, we’ll be forwarding this information to the developers so that they can look into it.

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.