Sorcery stations do not work after Sorcery S2 Update

, ,

Now that I’m able to play again, I can’t seem do anything at any of my sorcery stations. I’ve tried resetting my feats, but that has no effect. I have all the proper items needed to learn my next spell, but the button is still grayed out. I can’t raise zombies at a station or sacrifice people to collect blood or souls, etc., either.

I’m playing on PC, on a dedicated server. I am unsure yet if others are having this issue.

I should also note that we do not use any mods on our private server.

I’ve been able to use the stations again, but only for a short duration after I die, and then they become bugged again.

The zombie mound said that I was encumbered… which seems like an odd concern. I dropped my loot into a crate and got under 100% and voila, it works. So if you are having this bug you can’t do sorcery unless you are unencumbered.

The reason this worked was because I was naked, had no equipment and was unencumbered.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.