(SPOILER) ChaosMouth Altar is Missing

Game mode: Online
Problem: Bug
Region: North America

Just finished gathering the required items to create the keystone and remove my bracelet, went to the altar location but it wasn’t there just the statue and two braziers behind where it should be. I tried restarting the server but it didn’t restore it.

Steps on how to reproduce issue:

  1. Gather required items.
    2.Go to Chaosmouth altar.
    3.Realize there is no altar and awkwardly search other places confused.
    4.Come to the realization that the altar has decayed or something and is now lost to the world along with your only chance at freedom from the bracelet.

take a look here :

Thank you for the link, sadly none of the fixes there were able to help me but I’ll definitely keep tabs on it to see if anything else pops up that I can try.

Confirm this is happening on every private server I play on, the alter is gone with no means to combine the items.

It is happening in SP PC also, no chaos altar, hasn’t been one for weeks.

Same issue on US SP PC (Steam) server. No Altar.

And now that the game is out of early access, cannot switch between live server and testlive server as workaround.

I have heard that the altar is mising in test live also, you can still get into it but …

Just got to the Chaosmouth with all my stuff, ready to finally beat the game. There’s no altar here. Wooooo…

Altar is back :wink:

Concur, on my PC SP PVP the Chaos Altar is there again. Woo Hoo

Hey Delta. Testlive is still going on. You can switch at any time.
(You can actually see two patch note threads pinned in this section of the forums, one for Live and one for Testlive.)

Good luck! I can’t guarantee it’ll fix your problem, but it helped myself and at least a couple others.

Awesome. Was it due to the recent patch?

Altar came with the latest patch, yep… I tried it, and everything seems to work as intended.
That being said, I never experienced the problems some reported about it earlier either…

I don’t think that it was mentioned in the patch notes either…or at least I didn’t see a note that mentioned the Chaos mouth Altar was fixed, just glad that it is, now to just collect all of the items once again.