Stuck on loading screen -> Trying to connect to SA official server #1998

Whole story as short as possible: Was fighting an archer thrall, felt I was going to die so decided to run and cross a nearby river. While I was swimming, died to an arrow and corpse fell to botton of river -> select respawn point window popped up, selected bed (already was selected), respawn timer ended and nothing happened, I didnt respawn, and couldnt do anything else as nothing was happening… so I had to force end task the client.

After that reloaded the game, browsed SA official server #1998 again, found it, clicked on join, loading screen shows up and stays on it forever… nothing happens so I have to force end task the client again… tried again same thing. Did a game files validation on steam, all files validated successfully. Tried again, same thing.

Then uninstalled the game. Downloaded again and reinstalled, installed battleye, launched client, found server -> join -> stuck on loading screen again…

What is going on?

you were really lucky to still be able to play, at the moment this is one of the few servers that are not working properly in SA, more than half are not working, you get stuck in the loading screen in an infinite loop.

Os servers tão tudo fodido, tu não sai do loading, e se morre não consegue dar respawn, eles não tão conseguindo arrumar os servers já a mais de dois dias…

1 Like

esta difícil jogar desse jeito. para que teve então um período de acesso antecipado?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.