Stuttering and massive FPS drops when I use a wep or a tool

Game mode: Online official | Online private | Single-player
Type of issue: Performance
Server type: PvP
Region: EU

Stuttering and massive FPS drops when I use a wep or a tool.
Hello, I recently got back to Conan with Island of Siptha. I am however having big trouble with huge FPS drops. My machine has 16GB RAM running at 3.4k a M2 SSD, a Nvidia 1070 GPU a i9 k CPU and even when I run it at Old laptop mode, it has the same drops and stuttering. Any ideas ? I have been googeling looking for some answers but I come up short. Also I should mention I tried doing a complete wipe of the game and reinstalling. Same problems in MP and SP.

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:
1.Use a tool
2.when a tree breaks, or a stone breaks i get massive lagspikes.
3.When i hit someone or swing a wep i get massive lagspikes and fps drops.

Hey @mrwonder

Welcome to our community.
Are you playing with any mods installed?

Hey Ignasis, thanks!

No, not using any mods.

This is odd, we’ve seen no similar reports in the past. Just in case, do you have your graphic card and system drivers up to date?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.