Stygian Spear? Can't equip...what gives?

So while I was tooling around in the western highlands–specifically a small outpost just west-ish of New Asagarth–I discovered a Stygian Spear inside a loot box (the nice kind, not the wooden ones) inside one of those smaller watchtowers. It caught my eye because I adore all things Stygian (all hail Set); on further investigation, I realized it was at 100% intact-ness. (Can’t think of the proper word. :confused: ) Usually looted weapons are at maybe 10-15% health. Anyway, I snatched it up, and when I tried to equip it to try it out…I couldn’t equip it. Double-clicking did nothing, there was no “Use” or “Equip” button…I’m at a loss. I thought maybe it was because it’s a spear, and I haven’t put any Feat points into anything spear-related–i.e., “wth is this, how do I use it?” But then there’s that full health…have I run afoul of a bugged mod-related weapon? I do use Emberlight on my server.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.