Testlive Hotfix (21.06.2020) - Some music, AI and server browser fixes

Greetings, Exiles of the Testlive lands!

We’ve decided to deploy a new hotfix on Testlive to gather early feedback, while we keep focusing our efforts on the Live environment to stabilize performance and connectivity issues.

We’ve bundled in a few fixes dealing with some pending issues, such as AI pathfinding in the Well of Skelos, neverending combat music, some additional hate list issues, as well as some server browser problems.

Thanks again for your ongoing feedback and support, and stay safe.

Please remember that updates can mess with your installed mods. We suggest taking a backup of your current database before updating to any new patch if you have mods installed.



  • Made followers a little less prone to voluntarily walk into the lava in the Well of Skelos and be engulfed in fiery flames as if they were walking outside in Oslo these days.
  • Fixed additional hate list issues in the Warmaker dungeon and the Unnamed city.


  • Purge NPCs should no longer try to teleport inside a building when they can’t find their target.


  • Fixed an issue where Favorite Servers would not work as intended.
  • Steam query port for dedicated servers should work as before.
  • Added a few changes in regards of how mods are downloaded when required to join a server.


  • Last connected server should show up at the top of the server browser list again.


  • Combat music no longer plays indefinitely. It’s time to rest now, warrior.


Separate TestLive Product on Steam

We heard your input regarding the inconvenience with having to switch back and forth between the main game and our TestLive servers. To make it easier for you and because we really value your testing and feedback, we added a separate product for the TestLive server on Steam.

If you own Conan Exiles on Steam, you should now see a separate Product called “Conan Exiles - Testlive Client” in your library which gives you the option to install an additional instance of the game specifically for the TestLive servers. Please be aware that this will prompt you for a full additional installation.

We are aware that not everyone wants install or has space for two full installations. For those of you who don’t want to play through the additional TestLive Client, you can still access the TestLive servers through our old method.


If that is the extent of the changes to the Hate List, then consider me one very happy camper. Although could you all consider making the bandits and relic hunters hostile towards one another in sepermeru? I just dont see why the locals should turn a blind eye to their wrongdoings or even join forces with them to kill a wealthy traveller who has the ordasity to defend himself against their murderous intent. :laughing:

On a seperate note, I do hope you guys will consider tweaking the disparity between Thralls and Pets. But irrespective, I know you all have much on your plates at the moment and I thanyou kindly for the fixes and your ongoing support for this amazing game.


So there wont be a hotfix for the current problems anymore? @Ignasi


  • Combat music no longer plays indefinitely. It’s time to rest now, warrior.

… Does not work.
How to test :

  • makemeadmin
  • give yourself free run
  • teleportplayer -65000 258000

some humans are fighting down there.

  • Go through the battle, don’t fight, and run north,
  • Cross the whole river and wait on the riverside until you get bored of the combat music.

I’ve wished for this for quite some time now.


Combat Music fix didn’t work for me either, but the thrall pathing AI did.

Loaded a previous save in singleplayer mode on the testlive client. Inside Well of Skelos, starting point at the Obsidian Forge. Killed the 4 fighters and 1 snakeman at the forge. Ran through to the miniboss you must kill to open the door. After opening the door, proceeded to run past everything to the final boss, combat music played from here on. Killed the dungeon boss, music still going. Jumped down near the lava streams and tried to get myself lost and path across and parallel to as many sections of lava as I could find. I was able to get my thrall to teleport into the lava, but he wouldn’t remain standing in it. Thrall was a level 20, T2 archer from Set City. His inventory included 4 stacks of exotic feast, and I was never able to get him lower than 1/3 health. His engagement tactic on the behavior wheel was selected to “Guard Me”. Climbed back up to the normal path and killed everything I could find along my way back toward the dungeon exit. Combat music played the entire time. Only after exiting and returning to the Volcano did the music switch back to ambient music. I know for certain that I didn’t kill everything in the dungeon, but it was everything within reasonable distance from the main path.

On another note, I noticed that I was unable to damage my thrall. This shouldn’t be true for singleplayer mode unless there’s been a change. Will start a new game with verified server settings and test to ensure it isn’t an unintended artifact from loading a save from previous revisions.
Forced a new serversettings.ini file to be created and PvP was enabled, so I must have altered the setting and forgotten about it.

I would guess that they’re probably testing this hotfix right before rolling it out to live. But I would agree with you in that it would be good to get an official word on this.

Server browser appears to be back to normal, except for unusually high ping values. Prior to this patch, it was displaying all the live servers and I had to search for the testlive server.

Thanks for working on fixes. If you can also add the ‘no fall damage on private servers bug’ that would be awesome! Never thought I’d be excited about wanting to fall to my demise. :stuck_out_tongue:

1 Like

Combat Music, part 2

Testlive client. Started a new game in singleplayer mode. Traveled from game start location to the first exile camp located at
TeleportPlayer -62183.210938 250232.5625 -20053.103516
I gained aggro from them and the surrounding creatures, initiating the combat music, then ran eastward past several of the staged encounters until I reached
TeleportPlayer -22965.179688 260715.671875 -19553.925781
at which point I enabled the admin cheat Cloak. The only thing still following me at this point was a Black Kappa, and he seemed to drop aggro upon cloaking. The combat music continued to play.

I retraced my steps, walking to each encounter that I triggered and waited for each scenario to resolve before moving westward toward the next previous combat location. Ultimately I arrived back at the first exile camp, combat music still playing. I spawned in a quality weapon and killed the NPCs at the camp. Combat music continued. I once again retraced my steps heading eastward again, killing everything except for the juvenile shalebacks. After everything from the original run eastward was dead, then and only then did combat music stop (this is not new). But ambient music did not start (this is new). I walked back, hearing no music at all - only sound effects - to the original exile camp populated now by corpses and copied the teleport location. It was approximately at this time that ambient music resumed. I exited the game and began typing this post.

Realizing that I wanted to have a teleport location for the easternmost point of my run, I restarted the game and loaded the singleplayer save. New NPCs were properly in place, and I quickly enabled admin cheats and enabled cloak once again. This time, however, combat music stopped immediately upon cloaking and ambient music played. The NPC’s went to fight the nearby imp & shaleback. I walked back to the easternmost location, still cloaked, observing combat scenarios while the ambient music played. I copied the second teleport location and came back here to finish posting.

I won’t pretend to know how easy or difficult it is to fix this issue, but it is quite easy to test if you have in-house people to test it. Just start a new game, don’t enable any cheats, encounter something you don’t want to fight, and run away. Keep running until you don’t see anything that wants to kill you. It’s the same thing every player has done many times at some point or another. It happens daily with new players and veteran players. The newbs run because they don’t want to die. The veterans run because they don’t want the hassle.

Testlive client: Single Player (new play through for several hours)

Problem: Partial recognition of DLCs.

I have purchased all the DLCs offered. My live client games are completely fine. No issues. Everything works as its supposed to.

  • Testlive: Four DLCs are not recognized: Aquilonian, Khitan, Pictish, Yamatai

  • Testlive: Turan, Bloodletter, Poitain, and Argossean seems to work fine.

I thought maybe it was a glitch, so I logged out completely and started the game again. Same problem (only some DLCs are being recognized).

Also, AI pathing seems improved. Did not have any issues with continuous combat music so far.

1 Like

" * Steam query port for dedicated servers should work as before."

Does that mean online sites where people can look at the server info will work again?

Thank you for the work and fixes, hopefully the future updates will not have any gamebreaking issues like this one had/have!

1 Like

MODs DO NOT work in this testlive version. In Singleplayer subscribed mods do not show up when selecting MODS in main menu.
If on a dedicated server it stops at the mods screen and it say Queued and nothing more happen.

I only have one mod downloaded, the offline mode mod by hades. I tried to test it for a previous testlive patch and manually placed the .pak file in “…Steam/steamapps/common/Conan Exiles - testlive client/Conan Sandbox/Mods” folder. I never removed that file or folder from before. I just checked after reading your post, and the offline mode mod did display on the list of available mods from the main menu. I didn’t attempt to enable the mod, since it’s no longer functioning after the removal of Denuvo.

Someone can correct me if I’m wrong here, but as I understand it, mod subscriptions stored in the Workshop folder are subscriptions for the Live Client, not the Testlive Client. To check compatibility with the Testlive Client, you would need to manually add the mods to the appropriate subdirectory. To check compatibility of the subscriptions without adding the new content manually, you would need to use the Live Client but opt in to the beta branch from the Steam menu.

You know how it is in suburbs. People avoid local gangs of delinquents because they’re afraid they’d get into trouble themselves. However, when outsiders try to muscle their way into the 'hood, everyone rises up to defend the local kids.

What gets me is that one psychotic Bearer who wanders the city, charges at me as soon as he/she sees me at a distance, and pulls some guards into the fight too, even before I even raise my hand in self-defense.

But yeah, if e.g. panthers tried to eat baby deer instead of full-grown rhinos, the world might make a little more sense.



According to the debug HUD, the nominal ping I experienced during a brief play session was 72. The highest ping I observed was 112. According to the server browser, the ping for US3 was 251. So there’s something about the server browser’s mode of operation that is causing an artificially high ping value.

@Bodin @therryy


It worked on testlive before some time ago the usual way both singleplayer and dedicated server.

:arrow_up: THIS

I can understand what you wrote there but it is lacking on transparency WHEN we can expect a fix for the still existing problems. Because for example, some private servers are currently waiting for any news about an upcoming fix for the problems before they wipe. And the past testlive updates have been there mutliple weeks till they got rolled out. So approx. dates would be nice if there are any. Like are you just quick testing the hotfix or can we expect it to take a while…

Any dates we can share, we will.
Also please be aware that any remaining issues with private servers are mostly tied to the use of some mods.

1 Like