Thralls Sometime Uses Invisible Weapons

Basic Info:

Platform: Steam
Issue Type: Graphics
Game Mode: Single Player
Server Type: PvE
Map: Exiled Lands
Server Name: =SERVER NAME=
Mods: =MODS=


Bug Description:

Thralls will sometimes use invisible weapons. So far it has been crafted short shorts, Amir’s Tulwar and others. Weapon is visible in thrall inventory. After battle the weapon is not shown equipped on thrall.


Bug Reproduction:

Seems to be random. Perhaps when told to attack and the enemy is right in front of them… no idea.

Greetings RasterOps!
Thank you for reaching out to us.

In order for us to properly assess your issue, could you send us a video or screenshots of your thrall and their inventory showing the weapon being equipped and invisible at the same time please?

We’ll be waiting for your reply!


Equipped Weapon


Weapon On Back (sort-of)


Weapon in Use

Thank you for your reply RasterOps!

Is this happening only with simple weapons - like short swords - that you craft or with very specific, perhaps enhanced, weapons?

We’ll be waiting for your reply!

I (my thralls) mostly use short swords, Katanas, long swords and Axes. I sometimes use maces. I don’t recall this problem with axes, maces or bigger. IIRC even Amir’s Tulwar (no mods) went invisible and pretty sure it happened at least once with (iron) Katanas. But mostly with short swords.

I have been mostly using the perfected weapons (when avail.) and upgrading those as each Smithing Journey is completed. When weapon upgrades unlock I use those. A newly converted thrall may use their default weapon until I craft a replacement. I will also replace older weapons with newer ones when I get a crafter.

I tolerate things like this and don’t take notes. Then at some point after 100 hrs or more and seeing this bug repeatedly, I decide to post about it with foggy memories. I was surprised to find no other posts. So it’s probably just me. I have only seen this bug on thralls.

Thank you for your reply RasterOps!

Have you perhaps attempted any troubleshooting steps, such as verify your Conan Exiles files through Steam, reinstall your game or even check if this is happening to you in one of our Official Servers?

If not, we suggest that you attempt to verify the files by going to your Conan Exiles on Steam → right click it and go to ‘‘Properties’’ → Installed Files → click to ‘‘Verify’’, as well as reinstall your game if the former attempt doesn’t work.

Afterwards, let us know if the issue persists please!

Steam found two files that failed verification and reacquired them. So far so good.

Something seemingly random like this is difficult to confirm as fixed. But I’d say the likelihood is high. Sorry to be a bother.

No problem whatsoever RasterOps, we’re here to help!
Glad that everything is back in order with your account :slight_smile:

Continuation of a pleasant week!