[Troubleshooting] Cannot connect to Coop server (CAN connect on mobile internet)

Howdy all,

Summary:
I’m having issues connecting to a PC coop server. The problem is isolated between my router and the server. I am able to connect when using a mobile internet connection. Changing back to landline produces a connection lost.

Details:
My mate is hosting a coop server, and others are able to join and play. I cannot. (Error, below).

I have tried connecting by accepting an invite both from desktop and from the main menu.

I have tried connecting direct via IP and port.

When I try to connect, the error I receive is

Could not connect to server. Your connection to the host has been lost.

I am able to ping his IP.

I have tried forwarding a whole bunch of ports, as well as setting my PC to DMZ.

I have reset both modem and router, and have changed my WAN IP several times.

I have ensured my firewall and everything locally was disabled - ultimately irrelevant as I can connect while on hotspot.

I’m out of ideas, guys. If you have any suggestions, fire away.
Cheers,
-Dog

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.