Unable to place War Torn Ruins rubble pieces

Basic Info:

Platform: PlayStation 5
Issue Type: Gameplay
Game Mode: Online Official
Server Type: PvE
Map: Exiled Lands
Server Name: 3734


Bug Description:

I am unable to place any of the new war torn ruins building set rubble pieces anywhere. It says overlapping with another object or terrain regardless of where I try to place it.


Bug Reproduction:

Every time I try to place it. Zero success rate

Same here, unable to place them anywhere.

Still not fixed. You can’t charge us for a bazaar item and then not have it work and then not fix it. It’s been a week now. Either fix it or give partial credit. Seems this is an issue on all platforms.

This one would make a joke about the set of broken pieces being broken…

But this one remembers the over a month that the Aquilonian Porcelain throne was not included in the Aquilonian Spa set.

One would have hoped that the premium content has just a bit more QA applied…
But no.
This one now will not purchase until someone reviews the set and demonstrates that it all works.

1 Like

Almost two weeks and still not working.

It’s the same on PS4, still not fixed.

I think they’re hoping FOMO will make people buy it anyway or risk waiting 3 months for it to show up again in its less-broken state

But just think for a moment…
Fear of missing out on what?
Rubble.
Ruins.
Busted pieces for DLC set.

This isn’t the Stormglass Cathedral set we’re talking about here.

Who seriously is afraid of missing out on the opportunity to put selective battle damage on one DLC set? Especially when it has so many fewer snap points?

This one thinks Hanlon’s razor may apply in this case.

If there is a moustache being twirled, that’s a very sad moustache.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.