Upgrade to Premium - Internal error 500


#1

Hi,

When trying top upgrade to Premium account you are forwarded to page that gives the following error:

500 Internal Server Error
The server encountered an unexpected condition which prevented it from fulfilling the request.

Traceback (most recent call last):
File “/funcom/progs/python2.6/lib/python2.6/site-packages/cherrypy/_cprequest.py”, line 606, in respond
cherrypy.response.body = self.handler()
File “/funcom/progs/python2.6/lib/python2.6/site-packages/cherrypy/_cpdispatch.py”, line 25, in call
return self.callable(*self.args, **self.kwargs)
File “/funcom/servers/account.anarchy-online.com/common.py”, line 143, in updated
return f(self, *args, **new_kws)
File “/funcom/servers/account.anarchy-online.com/common.py”, line 272, in check
return f(self, *vpath, **inputs)
File “/funcom/servers/account.anarchy-online.com/server.py”, line 346, in payment_select
return serve(‘payment/select.html’, inputs)
File “/funcom/servers/account.anarchy-online.com/common.py”, line 44, in serve
data = template.render_unicode(inputs=inputs, cookie_consent=cookie_consent, session=inputs[‘session’]).encode(‘utf-8’)
File “/funcom/progs/python2.6/lib/python2.6/site-packages/Mako-0.9.1-py2.6.egg/mako/template.py”, line 452, in render_unicode
as_unicode=True)
File “/funcom/progs/python2.6/lib/python2.6/site-packages/Mako-0.9.1-py2.6.egg/mako/runtime.py”, line 807, in _render
**kwargs_for_callable(callable, data))
File “/funcom/progs/python2.6/lib/python2.6/site-packages/Mako-0.9.1-py2.6.egg/mako/runtime.py”, line 839, in _render_context
_exec_template(inherit, lclcontext, args=args, kwargs=kwargs)
File “/funcom/progs/python2.6/lib/python2.6/site-packages/Mako-0.9.1-py2.6.egg/mako/runtime.py”, line 865, in exec_template
callable
(context, *args, **kwargs)
File “templates_en_payment____masters_master_html”, line 26, in render_body
File “templates_en_payment_select_html”, line 71, in render_main_content
TypeError: float argument required, not NoneType


#2

Normal server?
Friday only


#3

Hi

From the account page there is a button to upgrade to Premium (we need this for the Progression servers i believe). When i click this and select recurring months I get the error. (Internal error - 500)


#4

Same issue here, getting internal error 500


#5

Thanks all for your reports - can you please try again? This should be fixed, now.


#6

Not fixed for me. Have only gotten error 500 when trying the special offer route to re-sub.


#7

The old site works, you can use:» register . Funcom . Com» massive annoyance that i can’t write the link outright :man_facepalming: