What is wrong with this game?

Again, I can’t play online. Over and over and over. I could yesterday. But not the night before. The day before, I could play online but not the night before that.

I can play offline, but I can’t play Isle of Siptah offline. It says ‘You do not own the required DLC to play on this server.’ I do own it, I play it everytime I manage to get online. Is it because I’m on Steam? If I bought another copy NOT on Steam, would you let me play then?

This is absolutely ridiculous.


It probably related to the country you are logging from. I have no issues with logging in using steam from Switzerland.

Are you in offline mode?
What is you connection like normally?
Are you having this issue with other games? Other steam games?
Have you tried a clean reinstall of Conan?


1 Like

I’m not in offline mode. I’ve checked the integrity of the files ad nauseum, logged in and out, tried logging in from Steam. This is the only game I’ve had this issue with, it’s very frustrating. Today, couldn’t get in but 3 hours later, it’s fine. My ping is under 100, I’m online everywhere else. This is so frustrating.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.