XP Multiplyers Not Registering Correctly

Hello Devs

Just wanting to let you know that the XP multiplyers in the Challenges menu are not registering the “X50” bonus. Still shows as “X 10” etc.

I play on PS4 on PVEc official server.

Anyone else seeing this issue?


1 Like

Have you completed a challenge to see if it gets replaced by a x50 one?

1 Like

Yes I’ve completed several. It still has the old multipliers on there. For reference Kiah On Fire on You Tube noted the same problem in her latest Conan video. You can see how the problem works in the video if interested.

1 Like

Having same issue. Still have old multipliers x10. I have done a few challenges and nothing changes. I have also tried what worked for Kiah on Fire, which she demonstrates in her latest video, still no luck with mine. Not sure if this makes a difference but I am currently on Siptah when trying this. I’ll give it a go on Exiled Lands. Playing on PC.


Thanks for confirming, completing some worked for me but apparently doesn’t work for all. Hope Funcom helps you out.


the only challenges I see getting the x50 are the top tiers (base 70 or 150). This could just be a coincidence as i rarely pursue completing the 30 and 40 tiers.

of course, now that i’ve reached rank 60 on the challenges i’ve little reason to bother with any of them regardless of x1, x10, or x50 multiplier.

Now, if every 1000 points after reaching rank 60 awarded some amount of crom coins, i could see continuing to grind the challenges… even when it repeats the events so often. (defeated tortured king, only to get the exact challenge repeated… defeat the tortured king)

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.