Can no longer equip my epic illusion armour after todays patch

So today xbox recieved its much needed patch, and it HAS fixed a lot of issues. However im now unable to equip my silent legion armour using the illusion for the acheronian legate armour?
I made the armour 2 days ago, and it had been working fine during that time. The armour is greyed out in my inventory however, and non illusion armours work fine!
Steps to reproduce
Log in to official pve server 2016 (xbox) > open inventory > attempt to equip pre made illusion armour.
I have attempted re logging/ rebooting the game to no avail. If i try to drag the armour on i recieve the message ‘you are not entitled to silent legion armour with an illusion from acheronian legate armour’.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.