Can not log in to dimension

When I try to log in I get the message that I am not authorized for that demension. This is the regular server and my account is paid.

Me too, WTH is going on now?

Same. I just came back after not playing since 2006. I’m just kind of shocked that a game I paid a monthly sub for, a 20+ year old game, still has stability issues? I was rubberbanding earlier too, felt like launch day stuff, very nostalgic

1 Like

Unfortunately it seem to be a ongoing issue for majority of people right now. There is no ETA on when this will be fixed.

1 Like

Is the server up, that response is a tad confusing. I was in, went through a wompah, ended up under the world, managed to zone back through and was still under the world. Then the game crashed and this dimension message we are all getting. Is that just how the crashing of the zone servers manifests? or was what I experienced just unrelated?

I am having the same issue

Hey, Corn_Pop. You got some unfinished business with your pal biden. :rofl:

2 Likes

Dude, I saw Corn Pop and thought about the same thing and thought nobody would get the reference if I said something. Maybe they like Corn Pops cereal? or, maybe he knows Joe from Joe’s days as a lifeguard, what do I know. I wish this game would come back up though, such nostalgia the game being down.

EDIT: apparently I only get 3 comments per topic, so I have to edit this one. I too am afraid they are trying to ninja shut this game down. I learned they are making a Dune MMO yesterday, and that has me nervous for the two co-existing. I also learned they are in NC, and now I’m super confused. I just left a 30+ year IT career, Funcom, y’all need me? I’d come back to fix this mess.

1 Like

Same here. crashed in game and can’t get back in on any accounts. Same message ‘No access to dimension’.

Still no update to this issue?

Expect an update after 0900 EST when the CS staff is back in the office in North Carolina.

Hello all, I’m having same issue and i’ve paid account till March 2024

ALL the AO servers are down. Started last night 'round 1800. It was Sunday & FC staff off for weekend. Discord is way more active there here for info… bring popcorn.

I think FC should append a note to all their communication messages regarding server issues. Like “This isn’t a step towards us shutting things down.” or, conversely, “This is the beginning of the end.”

The suspense over whether or not this is a covert attempt to shut down AO or not is a source of anxiety for the community, I think. :lol:

I cannot log into my dimension.

Unfortunately I tried all the usual stuff before coming here. Which reminds me. When I re-install how do I save all my bag settings? I have to reopen and set all my bags again.

dont reinstall, its not a problem on your end.

here’s a video to save settings

Thanks, I already re-installed. I also deleted my dimension file and tried to redownload it per a forum post on this issue.

I also reset my router to redo its DNS settings as I read that could be an issue…yea its been rough.

Yup. It’s most likely something dumb but I could see FC using it as the final straw for shut-down.

“Yup. It’s most likely something dumb but I could see FC using it as the final straw for shut-down.”

Maybe, however they are still making money so I bet they will not shut it down just yet.

I’m sorry for the inconvenience this is causing. This is being worked on and we hope to have the login issue fixed asap.