Cannot access Alter of the Bat: mod

Game mode: Online private, using Funcom Dedicated Server launcher app
Type of issue: Bug
Server type: PvE
Region: North America
Mods?: Yes
Edition: Steam

Bug Description:

At the Tower of the Bats, I defeated the Giant Bat. When I go up to the Alter of the Bats, it never shows up for me to open the inventory. Therefore I cannot put in the Staff of the Triumvirate. I have tried walking round it, looking in all directions, looking around the alter. Nothing ever appears. I have shutdown and started the server, which did not fix the issue. Also, after watching videos online, the alter looks different in my game. In the videos, the middle of the alter has a round stone, with a small hole, which looks like where the staff would go. In my game, that circle piece is missing; which I assume if the part which needs to be selected to access it.

Installed Mods:

If you answered ‘Yes’ to using mods, please list all your active mods. Otherwise, skip or delete this section.

(Pippi Server Manager, LitMan Level Three Twelve, Better Pets, 10xFeatsPerLevel, Less Building Placement Restrictions - v7.4.2, Pickup+, Animal and Horse Taming Places, Teir 4 Followers - Medium Increase Spawn -v5.7.5, Better Thralls v1.9.16, Waystones, Just No Rain Only, Thrall Food)

Steps to Reproduce:

Please provide a step-by-step process of how the bug can be reproduced. Please be as detailed as possible; the more details, the easier it will be for us to find and fix the bug:

  1. Go up the Tower of Bats
  2. Defeat the giant bat
  3. Walk up to the Alter of the Bat
  4. There is nothing which pops up in order to open the Alter of the Bat.
1 Like

I have figured out a workaround. I gave myself admin rights, then was able to spawn in the Alter of Bats. Once placed, I was able to active the Staff of Triumvirate. While this broke my gameplay experience for awhile, it at least allowed me to complete this step.

1 Like

Hi @blueblazer87, welcome to the forums!

Reading this I think a mod is the culprit somehow.

If you don’t mind testing, start a singleplayer game without mods and see if the issue still occurs.



Don’t know if this helps any. I play SP w/o mods and have no trouble accessing the Tower of Bats altar.

1 Like

Same for me, the official I play on doesn’t have the issue either.

That leaves mod issues or a rare bug.

1 Like

I agree, weird bug, probably caused by mods. I run a different server for me and someone else. When we went up there, it was working completely. At least, I could spawn in the alter using admin console for my solo run. I appreciate your responses :slight_smile:


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.