Cannot put Weapon Damage Kit on Star Metal Greatsword, but one spawned via admin worked

Basic Info:

Platform: Steam
Issue Type: Gameplay
Game Mode: Single Player
Server Type: PvE
Map: Exiled Lands
Server Name: None
Mods: None

Bug Description:

I crafted several Star Metal Great Swords with a T4 Bladesmith. When I tried to put an Advanced Weapon Damage Kit on one of them, I get the message that I cannot put kits on damaged weapons. Obviously I just crafted them and haven’t used them, so they aren’t damaged. I gave myself a Star Metal Greatsword via admin and I was able to put the kit on there without problem. Tried it on siptah for fun, also didn’t work.

Bug Reproduction:

Craft Star Metal Greatsword with a T4 Bladesmith. Tried to put an Advanced Weapon Damage Kit on it, got an error saying damaged items cannot be modified. Gave myself one of the swords via Admin, it worked without problem

It’s probably missing 1-2 durability. It needs to be full durability to add a weapon kit to it. Try repairing it first, and then retry applying that kit.

BTW ~ Welcome to the forum! :+1:

I crafted the weapons, have not used them, immediately walked over to the tinker’s bench and tried to apply the kit. Did not work.

I just tried repairing one of the weapons (which shows no damage and has full durability) and it says I cannot repair the item any more, because it has full durability

Same thing happens with Dragonbone bows, so it seems to be a bigger issue for me

Same for me too, just crafted a couple of star metal weapons, tried to use the advanced weapon damage kit and I had the same error message. I went to repair them but no repair option came up and anyway they’d only just been made by my T4 blade smith. Certainly looks like a bug.

I have this too. I think it’s related to crafting a weapon with the assistance of a thrall. I crafted a hardened steel shield without a thrall and I was able to mod it but the ancient mace I built with a T4 damage thrall at an improved armoursmith’s bench refuses to let me mod it with either a damage kit or spiked kit…

EDIT: In my case it seems a mod is causing it: “No Repair Bulls***” as weapons crafted without it seem to let me mod them fine.

Greetings @Narmiel,

Thank you for your report. Could record a short video showcasing the issue?

Also, can you share the name of the blacksmith you have on the workbench? If you tried any others please share their names too, please.

We await your reply.

Yeah, when I removed all the mods again it worked for me, but as soon as I put in the mod you mentioned, the error message came. I must have forgotten to take it out when I first tested it

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.