Cant login after update

the same servers in America i can load and play in exile lands but isle of siptah crashes to desk top same for single player and private servers all siptah maps crash i also tried on an xbox one x and on an xbox series x the results are the same

Same issue. Septah crashes to desktop after update 2.5

I’m pretty sure everyone is having this issue. Isle of siptah is broken.

1 Like

Tried loading into isle of siptah. Official server 2130 and I get dashboarded. Same thing happens to my tribe mates. After the new update. None of us can log on. Pls fix.

1 Like

I have also rwported the same bug for another isle of Siptah Server. I have also posted on their twitter. So far no response

Man I literally just bought the dlc a few days ago. Then this happens… Just hope they at least get it fixed soon.

This issue should now be resolved and you will be able to see a new update available in the store.

Please be sure to restart the store apps. This way you will trigger any downloads before retrying.

Thank you again for being so patient and understanding about this situation.


I loaded into siptah PVE on server 7050. It works! You did it funcom! Good job. I do notice slower load time getting in and losding up menus (i.e. benches) but at least I’m in. Thank you.


Issue is not fixed. Still unable to log into private server as it crashes to desktop everytime.

Thank you! Online works! Haven’t tried single player yet. Will later today and post. Good job. But I will say this should have been caught so clearly something is wrong with your testing scripts. A full review is required to ensure this doesn’t happen in future patches

2 posts were split to a new topic: Nergal bench issue?

I can play Septah now but where is the update 2.5? Its not in the store nor is there any available updates listed in my xbox Conan download manager.

Exciting. Thank you for fixing a Funcom


Download should kick in when you start the game saying it needs a update.

1 Like

Depending on your system and settings you might already have downloaded it.

My series X downloaded it while I was offline, but for some weird reason it didn’t show up in the recent updates area

It’s a big update so checking to how big your game file is would be a good way to know if you got it

Did u guys use an old patch for the siptah update? I have not crashed on siptah at all before the latest update. We r literally crashing every 20 mins. Plz fix. When siptah first came to xbox. It was running so smooth. What happened?

I’m having this same issue on 2 different accounts. One of which is solo so I’ve now lost my entire base. Luckily on the other account my clanmate has been able to refresh our timers.
The deal-breaker is this- for people who lose massive progress to decay coz we can’t log in? “Tough luck!”

Been playing, or trying to, for 4 years and I’m sorry but “it’s not our fault” is not adequate. There are day one bugs still in year 4, yet you pile more corrupt or faulty code on top… I really want to stay in favour of this game and funcom in general but…
And it just feels like it doesn’t matter to you all, you’ve got my money and there will be more people to give you theirs so forget me or anyone in this situation…
C’mon Funcom n G-portal, I’ll hold the faith for now…

1 Like

Cannot log to refresh decay timers on EL also. Are the timers suspended at least?

I only ask because 2 + years of CE is at stake for me…

1 Like

I am asking FC to address this, trying to gain support

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.