Clan emblem Heater Shield showing wrong emblem after being made illusion


Game mode: Official on two different servers.
Game type: PvP and PvE
TestLive client

We made a clan emblem heater shield, and after using a Thaumaturgy bench to use it as appearance in an illusion it gets a different clan emblem and no longer changes when the clan emblem is changed.

We tried with three different source stat shields and also on a 2nd test server. Result was same wrong emblem showing up, always same one. Also the image shown is not even available in the selection.

1 Like

As a Playstation player appreciate you and your friends testing for us. @fantasyshakira


Have you tried applying illusion first and then the emblem, if that’s even possible? Applying illusion removes dyes. Maybe it’s a similar problem, @fantasyshakira ?

The emblem is a constant on the emblem heater shield, so when you craft it it will show the current emblem at once. So that is not possible as I know. I am not sure if we tried to make one without first equipping the emblem heater shield once first, can try that at least.

If anyone else on the testlive could try this it would be interesting to know if they get the same bug.

1 Like

I hope they solve whatever is causing it.

I can confirm the Illusion system does not work on the Public Beta and we believe the symbol you see afterwards on your shield is a general placeholder. (Tested here). The same happens when you mount a shield on a shield display (or in case of mods, give a clan shield to a thespian).

One can only hope that this is being addressed at launch or shortly after, to add more value to these items.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.